#1  
Old 8th February 2007, 07:21
mgendys mgendys is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default PHP: Scripts dont execute!

I have followed the The Perfect Setup - OpenSuSE 10.2 (32-bit) instructions, almost word for word.

I use to have a SUSE 10.1 setup about 2 months ago, but that was a temporary test server, which funny enough actually worked.

This installation, which was going to be my webserver, seems to work with HTML but not PHP scripts.

I have tried to reinstall the whole system, I have tried to reinstall the PHP only, and I have read many similar problems and solutions, but with no luck.

The only thing I can come up with is that this might be that there is a bug in ISP Config 2.2.9, because it seems to work with 2.0.9 that I had on the test server, and the same problem occurs if I use SUSE 10.1 with 2.2.8/9.

Is there something I am missing or forgetting to do???
Or is there a simple solution that I have overlooked???
Reply With Quote
Sponsored Links
  #2  
Old 8th February 2007, 11:15
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default

Have you enabled suexec on the system.. try turning it on/off and then back on/off maybe a restart in between. the next is make sure that the permission ont he file have been set (reset) properly.

I must say that these fixes are for cgi stuff so not sure if the same works for php but its worth ago.

Thanks
Reply With Quote
  #3  
Old 8th February 2007, 12:10
mgendys mgendys is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mphayesuk
Have you enabled suexec on the system.. try turning it on/off and then back on/off maybe a restart in between. the next is make sure that the permission ont he file have been set (reset) properly.

I must say that these fixes are for cgi stuff so not sure if the same works for php but its worth ago.

Thanks
1) I have tryed checking the Suexec in the web panel of ISPConfig, I am not sure if there is a manual way of doing it through a script.
2) I restarted the machine and still no luck.
3) Changed the permissions on info.php file that I got from the test.zip on the forums, and still no luck.
4) I have unchecked the Suexec in the web panel.
5) I restarted again, and guess what...

STILL NO LUCK!!!

ANY OTHER IDEAS???

Does anyone know if this is a bug that is in ISPConfig 2.2.8/9 only???
Reply With Quote
  #4  
Old 8th February 2007, 13:29
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

Did you actually enable php for the site?
You can do so in the "base" tab.
Reply With Quote
  #5  
Old 9th February 2007, 12:23
mgendys mgendys is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by danf.1979
Did you actually enable php for the site?
You can do so in the "base" tab.
PHP enabled in ISPConfig, I have also tried to reinstall PHP and tried to mess around with apache.

I have also tried reinstalling ISPConfig and there is still no luck...

I am also begining to think maybe it is a problem in apache 2, that it is not running PHP, but I cant see that there is any issues in Apache!!!
Reply With Quote
  #6  
Old 9th February 2007, 12:48
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,495
Thanks: 835
Thanked 5,534 Times in 4,352 Posts
Default

I guess your problem is related to this issue:

http://www.howtoforge.com/forums/showpost.php?p=56261

we changed it already in SVN for the next relaese of ISPConfig. You can change it your sellf by replacing the line:

Quote:
$php .= "AddType application/x-httpd-php .php .php3 .php4 .php5\n";
with:

Quote:
$php .= "AddHandler application/x-httpd-php .php .php3 .php4 .php5\n";
in the file /root/ispconfig/scripts/lib/config.lib.php around line 1390
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 9th February 2007 at 12:54.
Reply With Quote
  #7  
Old 9th February 2007, 19:24
mgendys mgendys is offline
Junior Member
 
Join Date: Feb 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

THANKS TILL - THAT ACTUALLY WORKED!!!

Thanks all for your advice and support, this is the best support I have ever received on a forum, and it is great seeing the knowledge being shared around.
Reply With Quote
  #8  
Old 6th October 2007, 21:55
R0l@ndSm0ke R0l@ndSm0ke is offline
Member
 
Join Date: Dec 2006
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

After updating to version 2.2.17, I find that these issue remain unresolved. I have to update these files with every update to ISPConfig.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 10:29
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 10:54
ubuntu ispconfig joomla .htaccess steve1084 General 8 6th January 2007 16:55
VirtualHosts marra87 General 9 12th September 2006 05:09
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 14th March 2006 00:58


All times are GMT +2. The time now is 16:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.