#1  
Old 16th September 2006, 23:55
zarrelli zarrelli is offline
Member
 
Join Date: Jul 2006
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default <Location> not supported?

Hi,

I need to set up some configuration for an url, using the <Location> directive. I add the directives in the "Add directive" box in the admin panel, but in the Vhosts_ispconfig.conf I find them commented out as not supported. Here the relevant section stripped of personal data:


######################################
# Vhost: www.myhost.com:80
######################################
#
#
<VirtualHost xxx.xxx.xxx.xxx:80>
# <Location /my/location> # NOT SUPPORTED!
# DirectoryIndex index.php index.html index.htm # NOT SUPPORTED!
# Options +Indexes # NOT SUPPORTED!
# IndexOptions FancyIndexing IconsAreLinks SuppressHTMLPreamble NameWidth=* # NOT SUPPORTED!
# IndexIgnore HEADER* banner.gif favicon.ico # NOT SUPPORTED!
# AddIcon favicon.ico *myfile*.zip # NOT SUPPORTED!
# AllowOverride None
# </Location>
ServerName www.myhost.com:80
ServerAdmin webmaster@myhost.com
DocumentRoot /var/www/web11/web
ServerAlias myhost.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web11/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web11/log/error.log
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/var/www/web11/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web11/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web11/user/$1/web/$3
</VirtualHost>

Well, if I remove the # and restart apache...simply the <location> directive works perfectly but at the next change in the admin panel, all the <location> directive gets commented.

If it works, it is supported. And on another server I used this block of instructions for years without any problems.

I know I can move all to apache.con file, but I would like to keep everything in the vhost file.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 17th September 2006, 14:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What's the output of
Code:
httpd -t
when you remove the comments from
Code:
# <Location /my/location> # NOT SUPPORTED!
# DirectoryIndex index.php index.html index.htm # NOT SUPPORTED!
# Options +Indexes # NOT SUPPORTED!
# IndexOptions FancyIndexing IconsAreLinks SuppressHTMLPreamble NameWidth=* # NOT SUPPORTED!
# IndexIgnore HEADER* banner.gif favicon.ico # NOT SUPPORTED!
# AddIcon favicon.ico *myfile*.zip # NOT SUPPORTED!
# AllowOverride None
# </Location>
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th September 2006, 14:35
zarrelli zarrelli is offline
Member
 
Join Date: Jul 2006
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
What's the output of
Code:
httpd -t
when you remove the comments from
Code:
# <Location /my/location> # NOT SUPPORTED!
# DirectoryIndex index.php index.html index.htm # NOT SUPPORTED!
# Options +Indexes # NOT SUPPORTED!
# IndexOptions FancyIndexing IconsAreLinks SuppressHTMLPreamble NameWidth=* # NOT SUPPORTED!
# IndexIgnore HEADER* banner.gif favicon.ico # NOT SUPPORTED!
# AddIcon favicon.ico *myfile*.zip # NOT SUPPORTED!
# AllowOverride None
# </Location>
?
Here it is:

httpd -t
Syntax OK

But not only httpd -t gives me an ok, but If I go to the location, it behaves according to the instructions I gave in the <location> block. So, it works for sure on the system managed by ispconfig even though ispconfig comments.
Reply With Quote
  #4  
Old 18th September 2006, 11:08
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,710
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

Thats strange, as ISPConfig aclls httd -t to check the syntax. If you want to disable the syntay check, change the line:

$go_info["server"]["httpd_check"] = 1;

to:

$go_info["server"]["httpd_check"] = 0;

in the file /home/admispconfig/ispconfig/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 18th September 2006, 12:06
zarrelli zarrelli is offline
Member
 
Join Date: Jul 2006
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Thats strange, as ISPConfig aclls httd -t to check the syntax. If you want to disable the syntay check, change the line:

$go_info["server"]["httpd_check"] = 1;

to:

$go_info["server"]["httpd_check"] = 0;

in the file /home/admispconfig/ispconfig/lib/config.inc.php
I have not such a line there:

homeland:~# egrep -R httpd_check *
grep: blog/wp-content/advanced-cache.php: No such file or directory
ispconfig/scripts/writeconf.php:exec("ps ax | grep httpd | grep -v ispconfig | grep -v grep", $httpd_check, $ret_val1);
ispconfig/scripts/writeconf.php:unset($httpd_check);
homeland:~#

and:

homeland:/home/admispconfig# egrep -R httpd_check *
homeland:/home/admispconfig#

I never touched

/home/admispconfig/ispconfig/lib/config.inc.php

by hands
Reply With Quote
  #6  
Old 18th September 2006, 12:11
zarrelli zarrelli is offline
Member
 
Join Date: Jul 2006
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Default

A question:

does this happens just to me or someone else is able to cause the same behaviour adding a <location> directive?
Reply With Quote
  #7  
Old 19th September 2006, 14:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by till
Thats strange, as ISPConfig aclls httd -t to check the syntax. If you want to disable the syntay check, change the line:

$go_info["server"]["httpd_check"] = 1;

to:

$go_info["server"]["httpd_check"] = 0;

in the file /home/admispconfig/ispconfig/lib/config.inc.php
Till made an error, this option doesn't exist in ISPConfig. However, you could change the function httpd_syntax_check() in /root/ispconfig/scripts/lib/config.lib.php.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 7th February 2007, 01:25
xinman xinman is offline
Junior Member
 
Join Date: Dec 2005
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have this same problem. Has anyone found a good fix for this?
I added a line in apache.conf
Code:
Include /etc/apache2/vhosts/Vhosts_myaddons.conf
and then in the Vhost_myaddons.conf I added
Code:
<VirtualHost 192.168.1.2:80>
 <Location /mylocation>
#options for mylocation
 </Location>
 <LocationMatch '/[^/]+/login'>
#options for authentication
 </LocationMatch>
ServerName subdomain.domain.tld:80
</VirtualHost>
It works, but it would be kinda nice to have it editable in the ISPConfig Control Panel.

Just wondering,
Thanks,
Dan
Reply With Quote
  #9  
Old 8th February 2007, 20:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Quote:
Originally Posted by xinman
It works, but it would be kinda nice to have it editable in the ISPConfig Control Panel.

Just wondering,
Thanks,
Dan
This doesn't work without modifying the ISPConfig sources.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
Mepis not supported? dieselbenz Installation/Configuration 2 14th July 2006 16:45
Vhosts no longer written to whitty Installation/Configuration 15 3rd July 2006 22:37
Ruby on Rails Tutorial need help Geoinline Installation/Configuration 14 25th April 2006 02:28
quota format not supported by file system bobway54 HOWTO-Related Questions 1 15th August 2005 10:55


All times are GMT +2. The time now is 08:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.