Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd February 2007, 12:06
xyhfna xyhfna is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem Installing ISPConfig on a Debian System

I am running Debian 3.1 on an XEN virtual server on a Celeron processor.

After running through most of the configuration/setup scripts i get the following errors which i am having difficulty understanding. I have had to make a few minor tweaks to the scripts to get it to run (i.e. the path to mysql, which is located as standard at /usr/local/mysql). I have used the apt-get tool to install/update the relevant required programs. Below is the end of the information output to the terminal.

Please can anyone help/advise?
/root/ispconfig/openssl/lib/libcrypto.a(cryptlib.o)(.text+0x380): In function `CRYPTO_lock':
: multiple definition of `CRYPTO_lock'
/usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o)(.text+0x44): first defined here
/usr/bin/ld: Warning: size of symbol `CRYPTO_lock' changed from 7 in /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o) to 378 in /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o)
/root/ispconfig/openssl/lib/libcrypto.a(cryptlib.o)(.text+0x7b0): In function `CRYPTO_add_lock':
: multiple definition of `CRYPTO_add_lock'
/usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o)(.text+0x4c): first defined here
/usr/bin/ld: Warning: size of symbol `CRYPTO_add_lock' changed from 7 in /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o) to 156 in /usr/local/mysql/lib/libmysqlclient.a(libtaocrypt_la-misc.o)
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1
ERROR: Could not make PHP

cd: could not get current directory: getcwd: cannot access parent directories: No such file or directory
cd: could not get current directory: getcwd: cannot access parent directories: No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `spamassassin': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `uudeview': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `clamav': No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
./setup2: line 860: ispconfig_tmp/php/bin/php: No such file or directory
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
job-working-directory: could not get current directory: getcwd: cannot access parent directories: No such file or directory
Reply With Quote
Sponsored Links
  #2  
Old 3rd February 2007, 17:47
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

How much memory do you have in your virtual machine (free RAM and Harddisk=?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 3rd February 2007, 18:23
xyhfna xyhfna is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Celeron 1.0 GHz
RAM 128 MB
Raid 10 GB

Freespace: 8.5GB

no obvious memory errors/overflow, etc.
Reply With Quote
  #4  
Old 4th February 2007, 14:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's the output of
Code:
df -h
? From which directory are you trying to install ISPConfig?

Did you follow this guide: http://www.howtoforge.com/perfect_setup_debian_sarge to set up the system?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 4th February 2007, 14:50
xyhfna xyhfna is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

As stated above!

Filesystem Size Used Avail Use% Mounted on
/dev/sda1 9.9G 991M 8.5G 11% /
tmpfs 65M 0 65M 0% /dev/shm

out of curiosity, why?
i havent seen anything with regards to memory problems to my recollection.

As for the install directory i have tried both untarring in / and in /root, then cd to install_ispconf and running the setup script. (The script wont run from outside this dir as it uses local references [./] to chain load other scripts)

is there an obvious issue i have missed from the output?
Reply With Quote
  #6  
Old 4th February 2007, 15:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Ok, it was no space problem.

Did you follow this guide: http://www.howtoforge.com/perfect_setup_debian_sarge to set up the system?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 4th February 2007, 15:25
Ronin Ronin is offline
Junior Member
 
Join Date: Feb 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the excact same problem.

And I followed the perfect_setup_debian_sarge guide.

Also made sure that Bison, flex, gcc, zlib, libmysql12-dev, g++, cpp are all installed and up to date.

I use a 32-bit linux build and have no mem-problems.

I really have no Idea what to try next
Reply With Quote
  #8  
Old 4th February 2007, 16:15
xyhfna xyhfna is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am begining to think sarge is not the best platform for this, is Fedora Core 6 or CentOS 4 likely to be an any better platform for this, was going to get either one reinstalled instead of Debian and retry. I suspect it might have something to do with the fact a lot of packages are moved around or missing in Debian by default and some preinstalled versions are incompatible with ISPconfig.

Will get my hosting company to reinstall the server and try again.
Reply With Quote
  #9  
Old 4th February 2007, 16:35
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

Debian stable is one of the best platforms for this and debian has by default much more packages then fedora or centos.

Maybe your hosting company has messed up the setup by mixing up stable and unstable packages.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 4th February 2007, 19:17
xyhfna xyhfna is offline
Junior Member
 
Join Date: Feb 2007
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

After the last post, i decided NOT to have the sys-admin install anything other than Debian. It already has PHP5.2,MySQL,Apache/Apache2,BIND, and all other dependent packages installed. Followed the instructions again from scratch, litterally line by line incase i 'overlooked' something. Still there is a problem compiling the PHP5.2 binary. Is there anything i might have missed in the terminal output? anything that you might recommend i check? this is REALLY frustrating as i cant see what the 'problem' is.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig next day problem murphy.m.j Installation/Configuration 2 30th January 2007 16:21
ispconfig next day problem murphy.m.j Installation/Configuration 1 30th January 2007 02:37
Can't access ISPConfig on 2 month old system. digerata Installation/Configuration 3 21st August 2006 16:30
Problem with retrieving mail after using ISPConfig sw33t Installation/Configuration 8 14th May 2006 16:38
ISPConfig system stoped johnking Installation/Configuration 7 27th October 2005 02:37


All times are GMT +2. The time now is 20:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.