Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th February 2007, 10:28
cap10kirk cap10kirk is offline
Junior Member
 
Join Date: Dec 2006
Posts: 20
Thanks: 4
Thanked 0 Times in 0 Posts
Question 3rd party billing company can't FTP my site

I use CCBill for my third party billing company. I have absolutly no problems with the server, except for this wierd issue with CCBill. They are telling me that they can't connect to the server because of a time out error. For whatever reason, they can't FTP on their end. I can FTP all day long. It's not a firewall problem. I have no clue. and they aren't helping either. Any ideas on what the problem could be?

I'm not sure if they can ssh it. The server is not behind a firewall. I did not install a software firewall. Here is the error log:

*** CuteFTP Pro 3.3 - build Aug 25 2003 ***

STATUS:> Getting listing ""...
STATUS:> Resolving host name www.mysite.com...
STATUS:> Host name www.mysite.com resolved: ip = 12.34.56.789.
STATUS:> Connecting to ftp server www.mysite.com:21 (ip = 12.34.56.789)...
STATUS:> Socket connected. Waiting for welcome message...
220 ProFTPD 1.3.0 Server (Debian) [::ffff:12.34.56.789]
STATUS:> Connected. Authenticating...
COMMAND:> USER web1_mysite
331 Password required for web1_mysite.
COMMAND:> PASS *****
230 User web1_mysite logged in.
STATUS:> Login successful.
COMMAND:> PWD
257 "/var/www/web1" is current directory.
STATUS:> Home directory: /var/www/web1
COMMAND:> FEAT
211-Features:
MDTM
REST STREAM
SIZE
211 End
STATUS:> This site supports features.
STATUS:> This site supports SIZE.
STATUS:> This site can resume broken downloads.
COMMAND:> REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer
COMMAND:> PASV
ERROR:> Timeout (60000 ms) occurred on receiving server response.
ERROR:> Failed to establish data socket.

Thanks in advance fellas,
Kirk
Reply With Quote
Sponsored Links
  #2  
Old 5th February 2007, 11:46
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,406
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Is your server in a datacenter or hosted behind a router?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th February 2007, 18:53
cap10kirk cap10kirk is offline
Junior Member
 
Join Date: Dec 2006
Posts: 20
Thanks: 4
Thanked 0 Times in 0 Posts
Default

No, the server is in my home. I have not yet put a router in front of it. My cable modem is a gateway type of modem. I have a static IP address that goes straight through to the server.

Thanks again,
Kirk
Reply With Quote
  #4  
Old 6th February 2007, 07:40
cap10kirk cap10kirk is offline
Junior Member
 
Join Date: Dec 2006
Posts: 20
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Okay, I found this problem here: http://kb.globalscape.com/article.as...3&cNode=4K1J1P

is there anyway that i can fix my server so it doesn't have this problem?

Kirk
Reply With Quote
  #5  
Old 6th February 2007, 13:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by cap10kirk
Okay, I found this problem here: http://kb.globalscape.com/article.as...3&cNode=4K1J1P

is there anyway that i can fix my server so it doesn't have this problem?

Kirk
As far as I understand it it's not a server problem, but a problem with CuteFTP, so the CCBill guys have to change their CuteFTP settings.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 6th February 2007, 22:22
cap10kirk cap10kirk is offline
Junior Member
 
Join Date: Dec 2006
Posts: 20
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

You are right. I did get the issue resolved.

Thanks guys,
kirk
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP Error joshabts Installation/Configuration 3 4th November 2006 16:19
ftp problems tgansert Installation/Configuration 20 27th May 2006 19:06
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 08:03
Website users? ctroyp General 25 6th January 2006 18:02
FTP 101 the basics koegies Installation/Configuration 7 17th November 2005 15:55


All times are GMT +2. The time now is 10:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.