#1  
Old 20th October 2005, 18:48
chrisesler chrisesler is offline
Junior Member
 
Join Date: Oct 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail problems

I just installed the ubuntu hoary how-to steps, and everythign seemed to go well. my domain is dibolmi.com.

However, there seems to be a small email error. I can send out emails fine from the webmail interface.

But any emails I send back to the server do not get received. I've looked at the log, and there is nothing there. Its as if the mail doesn't even get to the server.

I checked out the dnsreport.com and for some reason it states that there is no MX records, when I know I added them.

Any help here would be appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 20th October 2005, 18:56
chrisesler chrisesler is offline
Junior Member
 
Join Date: Oct 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default I did an SMTP test

I just did a smtp test and here is the response I got...any ideas?

Quote:
OK, connected to dibolmi.com...
< 220 server1.dibolmi.com ESMTP Postfix (Ubuntu)
> HELO edit.dnsvr.com
< 250 server1.dibolmi.com
> MAIL FROM:<myemail@gmail.com>
< 250 Ok
> RCPT TO:<web1_info@dibolmi.com>
< 554 <web1_info@dibolmi.com>: Relay access denied
any clues to this?
Reply With Quote
  #3  
Old 20th October 2005, 19:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Can you check if dibolmi.com is in /etc/postfix/local-host-names?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 20th October 2005, 19:47
chrisesler chrisesler is offline
Junior Member
 
Join Date: Oct 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix file

heres the content of the file you asked about...

Quote:
###################################
#
# ISPConfig local-host-names Configuration File
# Version 1.0
#
###################################
localhost
server1.dibolmi.com
localhost.server1.dibolmi.com
localhost.dibolmi.com
www.dibolmi.com
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Reply With Quote
  #5  
Old 20th October 2005, 21:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

No, dibolmi.com is not in there. You created a web site for www.dibolmi.com in ISPConfig, right? Go to the Co-Domains tab and create the Co-Domain dibolmi.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 20th October 2005, 21:17
chrisesler chrisesler is offline
Junior Member
 
Join Date: Oct 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default another issue

I tried an nmap on port 53 for my nameserver and it stated it was closed. Why would that be? any help here would be grateful
Reply With Quote
  #7  
Old 20th October 2005, 22:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Can you post the output of
Code:
netstat -tap
? And maybe also of
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 28th October 2005, 17:02
Tribal-Dolphin Tribal-Dolphin is offline
Member
 
Join Date: Jul 2005
Location: Rives - Isre - FRANCE
Posts: 50
Thanks: 0
Thanked 1 Time in 1 Post
Default

Just a question :
why when we add a website, the localhostname file contains only www.domain.com instead of domain.com ?

Error when creating a new site OR ISPconfig mistake ?
__________________
Tribal-Dolphin
www.tribal-dolphin.net
Reply With Quote
  #9  
Old 28th October 2005, 17:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

When you create a new website, ispconfig adds automatically a co-domain without www. If you add a co-domain yourself with host www, you will have to add a second co-domain with an empty host.
Reply With Quote
  #10  
Old 28th October 2005, 17:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by Tribal-Dolphin
Just a question :
why when we add a website, the localhostname file contains only www.domain.com instead of domain.com ?

Error when creating a new site OR ISPconfig mistake ?
When you create a web site www.domain.com, the Co-Domain domain.com is created automatically, and both www.domain.com and domain.com are added to /etc/postfix/local-host-names so that you can receive emails for <user>@www.domain.com and <user>@domain.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 09:35
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Mail system problems. SkIRmiS Installation/Configuration 27 24th November 2006 17:45
internal domain error with mail matehortua Installation/Configuration 5 16th October 2005 18:31
saslauthd problem ... tmwtp Server Operation 11 16th October 2005 16:50


All times are GMT +2. The time now is 18:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.