Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th January 2007, 02:30
tolgata tolgata is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Gonna Loose My Mind About Permissions

I was using suse for several years but i never used a control panel and i decided to use ispconfig
I downloaded and installed it into my server(which is suse 10.2) and i added my domains to ispconfig howevery when i upload php files their default permissions are without execute(however folder's settings include execute) and when i try to run the index.php by giving it execute permission for everyone it doesnt execute ,it just try to download the index.php file like php support didnt enabled(but it did).
I'm gonna loose my mind why this is happening and I need a quick answer pls because my clients are extremly mad about this situation
Reply With Quote
Sponsored Links
  #2  
Old 9th January 2007, 02:48
tolgata tolgata is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

if this has no solution how can i uninstall it and turn everything back to normal
Reply With Quote
  #3  
Old 9th January 2007, 03:18
dragonslayer dragonslayer is offline
Junior Member
 
Join Date: Jan 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

do you have apache & php running, in YaST -> Network Services -> Network Services (xinetd) -> Toggle Status on...make sure everything is on,

as far as permission "chmod 777" which is rwx
Reply With Quote
  #4  
Old 9th January 2007, 07:19
Neg127 Neg127 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

What is the default umask in your ftp config file?

If you would like all directorys set to 755 and all files set to 644. You can make new files in the directory and also have the php or cgi files read and executed by default. You would need to set your umask to 022.
Reply With Quote
  #5  
Old 9th January 2007, 12:08
tolgata tolgata is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have changed the vsftpd.conf's local_umask variable to 022 however nothing changed the files I uploaded still seems as unexecutable to users.
And I also wonder how this will help me to execute php files instead of downloading them because when i give it execution permission by hand with chmod 755 ispconfig doesnt make it executable by client side it makes client to download php file like php doesnt work but it is
Reply With Quote
  #6  
Old 9th January 2007, 13:05
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
Originally Posted by tolgata
I have changed the vsftpd.conf's local_umask variable to 022 however nothing changed the files I uploaded still seems as unexecutable to users.
All FTP servers put your files with maximum rw-rw-rw permissions. It would be a real security concern if FTP'ed files were directly executable. Do it manually, so you know what you enable on a server.
If the chmod'ed 755 .php files are not executed in your webserver (I assume that's what you want), then your webserver configuration is not correct. Are you able to execute a simple php script in your web? Is a simple html file served properly?
Reply With Quote
  #7  
Old 1st February 2007, 16:34
isural isural is offline
Junior Member
 
Join Date: Feb 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Apache problem

I think your problem is apache config problem. If .php files downloaded from web server this means there is misconfiguration somewhere.
in httpd.conf you should check the configuration parameters carefully.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
munin permissions sjau HOWTO-Related Questions 10 17th April 2009 17:27
ISPConfig, postfix, dovecot: incorrect permissions arsen.gushin Installation/Configuration 9 4th March 2009 10:34
Pureftpd Permissions Problem GaulHahn Server Operation 6 17th October 2008 13:54
MySQL and Permissions and 'missing' db's jsabarese Server Operation 2 5th June 2006 23:07
Apache permissions misterm Installation/Configuration 4 8th September 2005 12:31


All times are GMT +2. The time now is 14:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.