Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th January 2007, 19:20
Martin Tort Martin Tort is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix and Ms Exchange 2000 Server

I love ispconfig. I m a Pc Supporter, i use ispconfig in some of my client. now a need to config a Single site ispconfig with Fedora Core 6 and rellay al incoming mail to a internal Exchange server. I tray a lot of changes but nothing function well. Please I need help to do this... Thk.
Reply With Quote
Sponsored Links
  #2  
Old 18th January 2007, 19:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Have you considered to set mailserver to external for all ISPConfig sites and then use postfix transports to forward incoming mails to the exchange server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th January 2007, 20:11
Martin Tort Martin Tort is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, I try to do this. I need to change the default setting of ISP Site - Options to Eternal Mail Server and then config the Transport option in the postfix main.cf file...
Reply With Quote
  #4  
Old 19th January 2007, 19:23
Martin Tort Martin Tort is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Till:
I have just done that you have suggested me and no function.

i send a copy of a mailog file

an 19 14:20:22 localhost dovecot: IMAP(m_alvarez): Disconnected: Logged out
Jan 19 14:20:22 localhost dovecot: imap-login: Login: user=<m_alvarez>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jan 19 14:20:48 localhost postfix/qmgr[5861]: warning: connect to transport smpt: No such file or directory
Jan 19 14:21:22 localhost dovecot: imap-login: Login: user=<m_alvarez>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.1, secured
Jan 19 14:21:22 localhost dovecot: IMAP(m_alvarez): Disconnected: Logged out
Jan 19 14:21:45 localhost postfix/anvil[6087]: statistics: max connection rat

my postmap -n

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
delay_warning_time = 2
home_mailbox = Maildir/
html_directory = no
mailbox_command =
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = /etc/postfix/local-host-names
mynetworks = 127.0.0.0/8, 10.0.0.0/24
newaliases_path = /usr/bin/newaliases.postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550

my transport files

# TRANSPORT(5) TRANSPORT(5)
#
# NAME
# transport - Postfix transport table format
#
# SYNOPSIS
# postmap /etc/postfix/transport
#
# postmap -q "string" /etc/postfix/transport
#
#
# The interpretation of the nexthop field is transport
# dependent. In the case of SMTP, specify a service on a
# non-default port as host:service, and disable MX (mail
# exchanger) DNS lookups with [host] or [host]ort. The []
# form is required when you specify an IP address instead of
# a hostname.
#
#
# LICENSE
# The Secure Mailer license must be distributed with this
# software.
#
# AUTHOR(S)
# Wietse Venema
# IBM T.J. Watson Research
# P.O. Box 704
# Yorktown Heights, NY 10598, USA
#
#
* smpt:[10.10.1.1:25]
Reply With Quote
  #5  
Old 19th January 2007, 22:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Please run
Code:
postmap /etc/postfix/transport
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 22nd January 2007, 19:57
Martin Tort Martin Tort is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko:

Still not funtion:

i copy a part of of my mailog


Jan 22 15:45:34 localhost postfix/smtp[17026]: 5C917BF48D: to=<m_alvarez@localhost.traditux>, orig_to=<malvarez@tradigrain.com.ar>, relay=10.10.1.1[10.10.1.1]:25, delay=69, delays=0.74/0.02/68/0.07, dsn=5.7.1, status=bounced (host 10.10.1.1[10.10.1.1] said: 550 5.7.1 Unable to relay for m_alvarez@localhost.traditux (in reply to RCPT TO command))
Jan 22 15:45:34 localhost postfix/cleanup[17022]: DBE1ABF485: message-id=<20070122184534.DBE1ABF485@localhost.traditux>
Jan 22 15:45:34 localhost postfix/qmgr[15642]: DBE1ABF485: from=<>, size=9385, nrcpt=1 (queue active)
Jan 22 15:45:34 localhost postfix/bounce[17050]: 5C917BF48D: sender non-delivery notification: DBE1ABF485
Jan 22 15:45:34 localhost postfix/qmgr[15642]: 5C917BF48D: removed
Reply With Quote
  #7  
Old 23rd January 2007, 18:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Please add localhost.traditux to /etc/postfix/local-host-names (at the bottom of the file) and also to /etc/hosts. Then restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 24th January 2007, 20:23
Martin Tort Martin Tort is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko

Now work all rigth. The problem was in the address in the destination domain. I m upgrade this an all work fine.

I have one more question

The clamav and the spamassasing is still working. Me be as not.
Reply With Quote
  #9  
Old 25th January 2007, 20:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by Martin Tort
I have one more question

The clamav and the spamassasing is still working. Me be as not.
What's the question?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 25th January 2007, 20:42
Martin Tort Martin Tort is offline
Junior Member
 
Join Date: Jan 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
 
Exclamation

Falko:

After do all of the steeps, the postfix foward all mail to the exchange server, but not detect any spam o virus in the new mails. I want to know if the mail is still cheked with the spammassasin or is forward direct to the exchange server. I need the spamm checking.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.