#1  
Old 1st November 2005, 00:51
ejkeebler ejkeebler is offline
Junior Member
 
Join Date: Nov 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Email from hostname

Ok I am still confused after reading through a few threads I thought resembled my issue.

Currently I can send and recieve email from name@server.domain.com I would like it to only be name@domain.com. Is this simply a hostname change? Or do I simply change a postfix value?

I am using Ubuntu 5.1 with, as I stated above, postfix.
Reply With Quote
Sponsored Links
  #2  
Old 1st November 2005, 09:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

How do you send the emails? With an email client such as Thunderbird or Outlook Express, with a command, from a script, etc?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st November 2005, 10:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

Do you use ISPConfig or have you configured your mailusers manually? Is your domain in the file /etc/postfix/local-host-names?
Reply With Quote
  #4  
Old 1st November 2005, 12:39
ejkeebler ejkeebler is offline
Junior Member
 
Join Date: Nov 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Answers

Yes I use an email client - Thunderbird and Outlook, and both can send emails to name@server.domain.com, but both get return to senders when sending to name@domain.com. When I send either from mailx or from thunderbord they arrive as name@server.domain.com

I am using Maildir, Postfix and Courier if that makes a difference.

As for the user mail clients setup, I do have ISPconfig installed but do not use it, as I really don't see the point since I just wanted to setup a working mail server, so.... I just create users with adduser and then send an email to that user@server.domain.com and tada, Maildir is created and that user has a mailbox.

Hope those answer the questions you had, thanks for the help!
Reply With Quote
  #5  
Old 1st November 2005, 12:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Have a look at this thread: http://www.howtoforge.com/forums/showthread.php?t=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 1st November 2005, 13:35
ejkeebler ejkeebler is offline
Junior Member
 
Join Date: Nov 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Still Broke

Thanks falko, I'm guessing I found the problem I checked my /etc/postfix/local-host-names and it had basically every possible domain combination in there:
localhost
server.domain
localhost.server.domain
localhost.domain
domain

so I checked my main.cf and I saw the mydestination line is commented out and does not contain "domain", it does have locahost etc. Could this be the issue?

I also checked the virtualusertable and did notice an entry probably from when I was messing around with ISPConfig trying to figure it out.

If this is the issue how does the server know that when mail is sent, to send it out as name@domain.com and not one of the others, like name@localhost.server.domain.com??

Thanks again

--Update
just uncommented the mydestination line and added domain.com to it, restarted postfix and when i send out mail it still comes as server.domain.com and when sending to name@domain.com, I have not received a return to sender (as I was before), but have not received the email yet either.

Last edited by ejkeebler; 1st November 2005 at 14:03. Reason: Update
Reply With Quote
  #7  
Old 1st November 2005, 14:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Did you run

Code:
postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
postconf -e 'mydestination = /etc/postfix/local-host-names'
Did you run
Code:
postmap /etc/postfix/virtusertable
after you've changed /etc/postfix/virtusertable?
All the information you need is in this post: http://www.howtoforge.com/forums/sho...=4&postcount=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 1st November 2005, 15:34
ejkeebler ejkeebler is offline
Junior Member
 
Join Date: Nov 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Well thanks anyway

Email is still not coming from name@domain.com but from name@server.domain.com instead and email still not being received when sending to name@domain.com, no big deal at least it works which was my goal, im sure I just didn't set a hostname value or something like that somewhere, I plan on setting up a new one again anyway

Thanks for all the help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about 'localhost' as Hostname Lil'Brudder Installation/Configuration 2 31st October 2005 09:58
Email sent to domain being rejected Lil'Brudder Installation/Configuration 9 25th October 2005 11:17
What should hostname be? Lil'Brudder General 2 19th October 2005 10:08
Server Hostname and IPSConfig Lil'Brudder Installation/Configuration 2 14th October 2005 12:46
UebiMiau webmail adding @localhostname to email address except first address. Kamran Shah Installation/Configuration 5 11th October 2005 17:01


All times are GMT +2. The time now is 23:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.