Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th January 2007, 00:09
Hidde Hidde is offline
Junior Member
 
Join Date: Jan 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default debian etch booting kernel 2.6.20-rc6

Yesterday I compiled my own kernel, by using the instructions from this howto by falko.
The compilation and installation went fine, but for some reason I can't boot into it. It probably has something to do with the fact that my sata disk are seen as scsi disk by linux, because before I get a kernel panic, the kernel is waiting for sda and sda2 (root) to show up. I wish I could post te complete error, but I can't seem to find it in the /var/log files.
Ofcourse I already tried google, but there are only a few hits, and they are all about virtualization with Xen. I hope someone can point my in the good direction, because I'm out of ideas.
Maybe you'd like some more info about my hardware: I've got only one sata disk that is connected to a motherboard with some RAID functions, but as far as i know it just works as JBOD (Just a Bunch Of Disks). It probably isn't even connected to a RAID supporting connector.

Edit:
This is my menu.lst :
title Debian GNU/Linux, kernel 2.6.20-rc6-default3
root (hd0,2)
kernel /vmlinuz-2.6.20-rc6-default3 root=/dev/sda2 ro
initrd /initrd.img-2.6.20-rc6-default3
savedefault

title Debian GNU/Linux, kernel 2.6.20-rc6-default3 (single-user mode)
root (hd0,2)
kernel /vmlinuz-2.6.20-rc6-default3 root=/dev/sda2 ro single
initrd /intird.img-2.6.20-rc6-default3
savedefault

title Debian GNU/Linux, kernel 2.6.18-3-amd64
root (hd0,2)
kernel /vmlinuz-2.6.18-3-amd64 root=/dev/sda2 ro
initrd /initrd.img-2.6.18-3-amd64
savedefault

title Debian GNU/Linux, kernel 2.6.18-3-amd64 (single-user mode)
root (hd0,2)
kernel /vmlinuz-2.6.18-3-amd64 root=/dev/sda2 ro single
initrd /initrd.img-2.6.18-3-amd64
savedefault

Last edited by Hidde; 27th January 2007 at 09:11.
Reply With Quote
Sponsored Links
  #2  
Old 28th January 2007, 19:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I guess some module is missing in your initrd.img-2.6.20-rc6-default3. Did you compile your kernel with SATA support?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th January 2007, 23:18
Hidde Hidde is offline
Junior Member
 
Join Date: Jan 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well, I'm not sure, but I think I did. I took the config file from my working stock kernel, And the only thing I changed is adding support for KVM. I'll check for SATA support in the morning. And I'll try google for those modules in initrd.
This afternoon I realized that my error is probably simular as the one in your howto. But I'm really sure "Fusion MPT device support" is compiled into my kernel.
Reply With Quote
  #4  
Old 29th January 2007, 12:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by Hidde
This afternoon I realized that my error is probably simular as the one in your howto. But I'm really sure "Fusion MPT device support" is compiled into my kernel.
You can check that in the kernel's config file in /boot.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th January 2007, 23:25
Hidde Hidde is offline
Junior Member
 
Join Date: Jan 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

config-2.6.20-rc6-default3:

#
# Fusion MPT device support
#
CONFIG_FUSION=y
CONFIG_FUSION_SPI=m
CONFIG_FUSION_FC=m
CONFIG_FUSION_SAS=m
CONFIG_FUSION_MAX_SGE=40
CONFIG_FUSION_CTL=m
CONFIG_FUSION_LAN=m

The only match for SATA in this file is:
#
# Please see Documentation/ide.txt for help/info on IDE drives
#
# CONFIG_BLK_DEV_IDE_SATA is not set

So, I guess I have to recompile my kernel with SATA support?
Reply With Quote
  #6  
Old 30th January 2007, 09:56
Hidde Hidde is offline
Junior Member
 
Join Date: Jan 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

In the config file for my working stock kernel I also found this line when searching voor SATA:

CONFIG_SCSI_SATA=m
CONFIG_SCSI_SATA_AHCI=m
CONFIG_SCSI_SATA_SVW=m
CONFIG_SCSI_ATA_PIIX=m
CONFIG_SCSI_SATA_MV=m
CONFIG_SCSI_SATA_NV=m
CONFIG_SCSI_PDC_ADMA=m
CONFIG_SCSI_HPTIOP=m
CONFIG_SCSI_SATA_QSTOR=m
CONFIG_SCSI_SATA_PROMISE=m
CONFIG_SCSI_SATA_SX4=m
CONFIG_SCSI_SATA_SIL=m
CONFIG_SCSI_SATA_SIL24=m
CONFIG_SCSI_SATA_SIS=m
CONFIG_SCSI_SATA_ULI=m
CONFIG_SCSI_SATA_VIA=m
CONFIG_SCSI_SATA_VITESSE=m

I guess this is why my kernel isn't working, but why wasn't it enabled when I compiled it? I know for sure that I loaded this config file in menuconfig.
Reply With Quote
  #7  
Old 30th January 2007, 12:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by Hidde
In the config file for my working stock kernel I also found this line when searching voor SATA:

CONFIG_SCSI_SATA=m
CONFIG_SCSI_SATA_AHCI=m
CONFIG_SCSI_SATA_SVW=m
CONFIG_SCSI_ATA_PIIX=m
CONFIG_SCSI_SATA_MV=m
CONFIG_SCSI_SATA_NV=m
CONFIG_SCSI_PDC_ADMA=m
CONFIG_SCSI_HPTIOP=m
CONFIG_SCSI_SATA_QSTOR=m
CONFIG_SCSI_SATA_PROMISE=m
CONFIG_SCSI_SATA_SX4=m
CONFIG_SCSI_SATA_SIL=m
CONFIG_SCSI_SATA_SIL24=m
CONFIG_SCSI_SATA_SIS=m
CONFIG_SCSI_SATA_ULI=m
CONFIG_SCSI_SATA_VIA=m
CONFIG_SCSI_SATA_VITESSE=m

I guess this is why my kernel isn't working, but why wasn't it enabled when I compiled it? I know for sure that I loaded this config file in menuconfig.
Maybe these options have been replaced in newer kernels?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 16th February 2007, 09:56
olshevch olshevch is offline
Junior Member
 
Join Date: Feb 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I had the same problem, when I compiled kernels with Debian stock configuration.
The problem waas solved, when I compiled with command:
Code:
make-kpkg --initrd kernel_image
in kernel source root directory, and installed with command:
Code:
dpkg -i linux-image-2.6.20-10.0.Custom-amd64.deb
(I compiled on amd64 system.)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
Xen 3.0.2 /3.0.3 | No Swap in DomU Merc HOWTO-Related Questions 10 27th March 2007 11:40
WG311v2 almost working with Edgy (w/o ndiswrapper) need help with the rest caudata Server Operation 11 13th November 2006 20:02
Problems installing NForce4 sound drivers Wraithfire Installation/Configuration 21 16th April 2006 17:30
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 12:59


All times are GMT +2. The time now is 22:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.