Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 9th February 2007, 15:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Did you enable "Server requires authentication." in your email client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 9th February 2007, 20:39
sremac sremac is offline
Junior Member
 
Join Date: Feb 2007
Location: Belgrade
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default yes but...

Situation is:

mail clients are setup on right way, and when turned on smtpauth in main.cf server asks user/pass and it works, also when turned off smtpauth on main.cf server don`t ask, but mail can be sent from IP`s that are not in mynetworks in main.cf?

What option in main.cf tells not to send mails from not-defined networks?


main.cf:

...
mynetworks = 127.0.0.0/8, 192.168.2.0/24
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks,permit_sasl_authenticated,reject _unauth_destination
...

Thanx!
Reply With Quote
  #13  
Old 9th February 2007, 21:56
sremac sremac is offline
Junior Member
 
Join Date: Feb 2007
Location: Belgrade
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default well

On Internet are lot of explanation, but still problems

http://www.postfix.org/SMTPD_ACCESS_README.html

This option is making problems to me:

smtpd_client_restrictions = permit_mynetworks, reject

when I turn it on in main.cf, server responds:

mail from:<igor@virtual.test>
250 2.1.0 Ok
rcpt to:<igor@virtual.test>
451 4.3.5 Server configuration error


when trying to aproach from different network.

So, what options need to be turned in main.cf in order to:

1. check mynetworks and allow everything from that
2. if mynetworks don`t pass then to use smtp auth

?
Reply With Quote
  #14  
Old 10th February 2007, 20:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by sremac
On Internet are lot of explanation, but still problems

http://www.postfix.org/SMTPD_ACCESS_README.html

This option is making problems to me:

smtpd_client_restrictions = permit_mynetworks, reject

when I turn it on in main.cf, server responds:

mail from:<igor@virtual.test>
250 2.1.0 Ok
rcpt to:<igor@virtual.test>
451 4.3.5 Server configuration error


when trying to aproach from different network.

So, what options need to be turned in main.cf in order to:

1. check mynetworks and allow everything from that
2. if mynetworks don`t pass then to use smtp auth

?
It's all in the tutorial ( http://www.howtoforge.com/virtual_po...ota_courier_p2 ). Please run
Code:
postconf -e 'smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination'
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 29th May 2007, 17:21
peo peo is offline
Junior Member
 
Join Date: May 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to peo Send a message via MSN to peo
Default

Quote:
Originally Posted by jacob
When the doc says
Then edit /etc/authlib/authmysqlrc. It should look exactly like this (again, make sure to fill in the correct database details):

It really should be exactly

I had a space at the begining of the third line from the bottom
Yeah, i checked my file and solved! thanks!!
Reply With Quote
  #16  
Old 8th October 2007, 22:30
AdamBoyle AdamBoyle is offline
Junior Member
 
Join Date: Oct 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Error in 7.04

Hi,

This tutorial is brilliant, just what I've been looking for, I am having a problem in connecting to the server via my mail client though.

I'm getting the error: "sending the password did not succeed. mail server [myhost] responded: chdir [myhost]/[myuser]/ failed."

I've noticed the file doesnt exist in my /home/vmail directory and have tried sending a few emails through to try and force-create it but the mails keep getting bounced back. Both the user and domain are set up in the mysql database and I'm pretty stumped for ideas from now

Any help would be very much appreciated!
Reply With Quote
  #17  
Old 9th October 2007, 23:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are there any errors in your mail log (/var/log/mail.log)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
PhilyWisk (20th February 2008)
  #18  
Old 20th February 2008, 20:49
PhilyWisk PhilyWisk is offline
Junior Member
 
Join Date: Feb 2008
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Had the same issue as AdamBoyle, some domains would work some wouldn't, turned out that the domain that wouldn't was named as mydesination setup back on page 2 of the tutorial:

Code:
postconf -e 'myhostname = server1.example.com'
postconf -e 'mydestination = server1.example.com, localhost, localhost.localdomain'
Just put a www. in front of the domain, don't know if that's a good thing to do or not but it worked.

Last edited by PhilyWisk; 20th February 2008 at 22:05.
Reply With Quote
  #19  
Old 4th November 2008, 13:22
far.east far.east is offline
Junior Member
 
Join Date: Nov 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default relay=virtual...

i think transport must be commented, so in maillog it is known as virtual
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL Secondary MX acoghlan HOWTO-Related Questions 1 8th March 2008 05:02
Virtual Users And Domains With Postfix, Courier And MySQL [+ procmail ?] immobilia HOWTO-Related Questions 5 29th June 2006 23:20
Virtual Users And Domains With Postfix, Courier And MySQL - "apt-get" and Courier burritonator HOWTO-Related Questions 3 15th March 2006 20:11
Problem with Virtual Users And Domains With Postfix, Courier And MySQL Howto fenix Server Operation 4 11th March 2006 02:53
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 02:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.