Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th January 2007, 23:03
zokahn zokahn is offline
Junior Member
 
Join Date: Jan 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default symlink problem... Symbolic link not allowed

Hi,

At the moment i´m migrating sites to new hardware. copying files and making stuff work. I use geeklog in many cases.

I´ve made geeklog work by replacing the /local/www/web#/web dir to a symlink pointing to /local/www/web#/geeklog/public_html Normaly that works. but now on one particular site i get a forbidden error and this is in my log:

[Wed Jan 10 22:34:00 2007] [error] [client 123.123.123.123] Symbolic link not allowed: /local/www/web#/web

It´s a mystery to my why one site works while another does not.

Gr,
Zokahn
Reply With Quote
Sponsored Links
  #2  
Old 11th January 2007, 08:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Does this website has a .htaccess file or any additional settings in the apache directives field? Or does all other sites have some additional settings in .htaccess or apache directives field?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th January 2007, 08:43
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Do you have in either apache2.conf or a .htaccess or the ISPConfig web directives specified
Code:
Options +FollowSymLinks
for this directory?
Reply With Quote
  #4  
Old 11th January 2007, 10:42
zokahn zokahn is offline
Junior Member
 
Join Date: Jan 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'll try it. However i did nothing of this kind to other dirs or files for the sites that do work. It's also a bit strange that the error is about the document root (the /local/www/web#/web dir itself)

I would expect that the directives would be active for only the /local/www/web#/web subdirs. But that maybe false...

gr,
Zokahn
Reply With Quote
  #5  
Old 11th January 2007, 10:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Quote:
Originally Posted by zokahn
However i did nothing of this kind to other dirs or files for the sites that do work. It's also a bit strange that the error is about the document root (the /local/www/web#/web dir itself)
Thats why I asked for this informnation:

http://www.howtoforge.com/forums/sho...13&postcount=2
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 25th January 2007, 11:03
zokahn zokahn is offline
Junior Member
 
Join Date: Jan 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks for looking into this... I think the problem is with the website i'm trying to setup.

I tried to link to a new dir with just one html file, that works perfectly. Sooooo the problem is nog ispconfig related.

Again thanks for your time.

Gr,
Bart
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
.htaccess and .htpasswd files in symbolic link directories. tarndt Installation/Configuration 4 26th July 2006 10:28
colocation problem d3m0nic Installation/Configuration 14 23rd June 2006 23:18
Ispconfig and Virtuemart shajazzi Installation/Configuration 7 21st February 2006 20:25


All times are GMT +2. The time now is 04:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.