Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st October 2005, 18:00
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default Cyrus IMAP Configuration ??

I'm still having trouble setting up the default IMAP server that the Perfect Setup - Fedora Core 4 guides me to install. It should be the suite of cyrus apps.

I've tried installing it to the letter 2 times, but I still can't get my IMAP client (Outlook Express) to connect to the server.

Just to let you know, the POP, SMTP, Web, Shell, etc. servers are all running smoothly and looks like there are no problems. It just seems to be the IMAP service.

I don't think it is a firewall problem because the server is connected with port 143 open (I think that is the default port for IMAP).

Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 21st October 2005, 18:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Is your imap server listed when you execute: netsta -tap

Do you get any errors when you start your imap server or are any errors in the messages or syslog?
Reply With Quote
  #3  
Old 21st October 2005, 18:41
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

This is what is listed when I run netstat -tap:

******************************************

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address Stat
e PID/Program name
tcp 0 0 *:imaps *:* LIST
EN 8922/xinetd
tcp 0 0 *:32769 *:* LIST
EN 1676/rpc.statd
tcp 0 0 *op3s *:* LIST
EN 8922/xinetd
tcp 0 0 *:mysql *:* LIST
EN 2119/mysqld
tcp 0 0 *op3 *:* LIST
EN 8922/xinetd
tcp 0 0 *:imap *:* LIST
EN 8922/xinetd
tcp 0 0 *:sunrpc *:* LIST
EN 1659/portmap
tcp 0 0 *:81 *:* LIST
EN 2416/ispconfig_http
tcp 0 0 *:ftp *:* LIST
EN 26908/proftpd: (acc
tcp 0 0 70-88-225-1-knife-ce:domain *:* LIST
EN 3922/named
tcp 0 0 mail.knifecenter.com:domain *:* LIST
EN 3922/named
tcp 0 0 mail.knifecenter.com:ipp *:* LIST
EN 1971/cupsd
tcp 0 0 mail.knifecenter.com:5335 *:* LIST
EN 1955/mDNSResponder
tcp 0 0 *:smtp *:* LIST
EN 26995/master
tcp 0 0 mail.knifecenter.com:rndc *:* LIST
EN 3922/named
tcp 0 0 *:http *:* LIST
EN 2607/httpd
tcp 0 0 *:ssh *:* LIST
EN 2018/sshd
tcp 0 0 ::1:rndc *:* LIST
EN 3922/named
tcp 0 0 *:https *:* LIST
EN 2607/httpd
tcp 0 0 70-88-225-1-knife-cente:ssh ::ffff:10.1.10.19:60451 ESTA
BLISHED 24910/0

Quote:
Originally Posted by till
Is your imap server listed when you execute: netsta -tap

Do you get any errors when you start your imap server or are any errors in the messages or syslog?
Reply With Quote
  #4  
Old 21st October 2005, 18:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Check your Xinetd configuration ( in /etx/xinetd/) which imap binary is connected to the imap port. And what about my 2. question: Any errors in the mail log or syslog?
Reply With Quote
  #5  
Old 21st October 2005, 18:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

That looks ok. IMAP is running. Maybe you have a firewall on your client computer (where Outlook Express runs) that doesn't allow connections to port 143?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 21st October 2005, 19:24
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Angry

I tried a different IMAP client (Mozilla Thunderbird). I get the following message:

Mail server mail.knifecenter.com is not an IMAP4 mail server.

This is so frustrating!

Quote:
Originally Posted by falko
That looks ok. IMAP is running. Maybe you have a firewall on your client computer (where Outlook Express runs) that doesn't allow connections to port 143?
Reply With Quote
  #7  
Old 21st October 2005, 21:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Have you checked the things I've posted above?
Reply With Quote
  #8  
Old 21st October 2005, 21:18
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

Where are the syslog and messages log files? I will post them if you tell me where the logs are located.

Quote:
Originally Posted by till
Have you checked the things I've posted above?
Reply With Quote
  #9  
Old 21st October 2005, 21:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Log files are in /var/log. Dont post the complete logfiles here, they are too large. Search for IMAP errors and post the errors here.
Reply With Quote
  #10  
Old 21st October 2005, 21:21
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

This is the xinetd conf file:

************
#
# Simple configuration file for xinetd
#
# Some defaults, and include /etc/xinetd.d/

defaults
{
instances = 60
log_type = SYSLOG authpriv
log_on_success = HOST PID
log_on_failure = HOST
cps = 25 30
}

includedir /etc/xinetd.d

********************************

Quote:
Originally Posted by till
Check your Xinetd configuration ( in /etx/xinetd/) which imap binary is connected to the imap port. And what about my 2. question: Any errors in the mail log or syslog?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Setup... IMAP help??? leon HOWTO-Related Questions 7 7th August 2008 16:17
Loading configuration file lance Kernel Questions 2 28th February 2007 20:40
IMAP & POP3 FC3 Samer A. Yaghi Installation/Configuration 6 17th October 2005 12:54
Courier IMAP - when does it delete deleted messages?? hagel Server Operation 3 18th August 2005 23:52
30 Default Imap Folders? adamluz Installation/Configuration 9 18th August 2005 23:45


All times are GMT +2. The time now is 14:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.