Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th January 2007, 16:30
bss bss is offline
Junior Member
 
Join Date: Dec 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Mail stoped working !!!!

I have a problem simmilar to http://www.howtoforge.com/forums/showthread.php?t=9877
and i checked everything that should be working is ok (in log it looks at the mail was sent).
But when i send mail from webmail or from outlook even to local address i dont get that mail.. I cant neither send or recive mail!!!... The configs are ok becouse I have made an backup of whole harddisk while it was working...

Please helP!!!!!!
Reply With Quote
Sponsored Links
  #2  
Old 19th January 2007, 16:37
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Lightbulb More information please

Just shouting something does not work and expect on such a brief statement an answer that will immediately solve your problems will not work, not on this forum, not on any other. You have to be more descriptive and supportive to all the people here trying to help others. Please calm down and provide some more info about what's not working precisely. Try to break your problem(s) into pieces and address them one-by-one. Only then you can expect to receive some help.

Let start with to installation you have? Linux version? ISPConfig? Postfix? Maildir support?

if yes, what's the output of the Maildir directory of a local user you're trying to sent mail to? A
Code:
ls -l
output would be helpful.
Reply With Quote
  #3  
Old 19th January 2007, 17:01
bss bss is offline
Junior Member
 
Join Date: Dec 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
root@server:/var/www/web4/Maildir# ls -l
total 28
drwxrwxrwx 2 bss.si_admin web4 4096 2007-01-14 08:56 courierimapkeywords
-rw-r--r-- 1 bss.si_admin web4   36 2007-01-14 16:59 courierimapsubscribed
-rw-r--r-- 1 bss.si_admin web4   20 2007-01-18 16:20 courierimapuiddb
-rwxrwxrwx 1 bss.si_admin web4   61 2007-01-14 09:37 courierpop3dsizelist
drwxrwxrwx 2 bss.si_admin web4 4096 2007-01-18 16:20 cur
drwxrwxrwx 2 bss.si_admin web4 4096 2007-01-18 16:20 new
drwxrwxrwx 2 bss.si_admin web4 4096 2007-01-18 16:23 tmp
Sorry for the anger.... i lost my nerves... it all worked .. and i didn't do nothing... it just stopped working...

If i send a mail to my self it goes thru ok.
in log:
Code:
Jan 19 16:24:55 server postfix/local[23516]: 538FB24C39F: to=<bss.si_info@server>, orig_to=<info@bss.si>, relay=local, delay=0.19, delays=0.09/0/0/0.1, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Jan 19 16:24:55 server postfix/qmgr[10510]: 538FB24C39F: removed
and i don't get the mail...

I have Ubuntu 6.10 amd64 with ISPconfig version 2.2.9, maildir enabled...
I dont even get the mail if I send it from the command line..and i have no idea..remains just new installation.

Last edited by bss; 19th January 2007 at 17:05.
Reply With Quote
  #4  
Old 19th January 2007, 17:07
bss bss is offline
Junior Member
 
Join Date: Dec 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Could it be something in the local hostname??
Reply With Quote
  #5  
Old 19th January 2007, 17:24
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Anything in the Maildir/new subdirectory that resembles the just sent email?

I see a difference with my logs in respect to the procmail part, but I'm not sure it that's the cause.
Code:
Jan 19 06:00:08 tmpoeu01 postfix/local[19394]: 82C331AC061: to=<web1_user@tmpoeu01.domain.tld>, orig_to=<root>, relay=local, delay=7.2, delays=1.7
/0.01/0/5.4, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
domain.tld is obfuscated in this example. I see in the Maildir/new (as long as I have not opened it, then it will move to the 'cur' subdir) the message sent here.

hostname -f gives on my system tmpoeu01.domain.tld, but I have specifically set it to this with the hostname command and I changed /etc/hostname. But you had this working, so I shouldn't start to look there (unless you did some DNS or hostname changes.

edit: negation typo error
Reply With Quote
  #6  
Old 20th January 2007, 18:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

What's the output of
Code:
netstat -tap
? Is Maildir enabled in ISPConfig (Management -> Server -> Settings -> Email)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 22nd January 2007, 13:46
bss bss is offline
Junior Member
 
Join Date: Dec 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes ... i have maildir enabled

Code:
root@server:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN     3424/mysqld
tcp        0      0 *:81                    *:*                     LISTEN     3854/ispconfig_http
Reply With Quote
  #8  
Old 22nd January 2007, 17:27
bss bss is offline
Junior Member
 
Join Date: Dec 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have found the problem but now i don't know how to solve it...
The problem is... When i recive mail with postfix it doesn't deliver the mail to my ISPconfig created directory (eg. /var/www/web4/user/bss.si_info/Maildir)
but to /var/mail(mailbox?!? not maildir?).
my /etc/postfix/main.conf:
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
#smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
#smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
#smtpd_use_tls=yes
#smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
#smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
#mydestination = server, localhost.localdomain, , localhost
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_path = smtpd

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names

relayhost = 
inet_interfaces = all
home_mailbox = Maildir/ ## is this right?
mailbox_command = procmail -a $EXTENSION
Reply With Quote
  #9  
Old 22nd January 2007, 17:30
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

What's in /etc/postfix/virtusertable?
Reply With Quote
  #10  
Old 22nd January 2007, 17:32
bss bss is offline
Junior Member
 
Join Date: Dec 2006
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Code:
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
hostmaster@www.oblika.si    oblika.si_hostmaster
oblika.si_hostmaster@www.oblika.si    oblika.si_hostmaster
hostmaster@oblika.si    oblika.si_hostmaster
oblika.si_hostmaster@oblika.si    oblika.si_hostmaster
admin@www.darovi-narave.si    darovi-narave.si_admin
darovi-narave.si_admin@www.darovi-narave.si    darovi-narave.si_admin
admin@darovi-narave.si    darovi-narave.si_admin
darovi-narave.si_admin@darovi-narave.si    darovi-narave.si_admin
admin@www.dezela-skratov.com    dezela-skratov.com_admin
dezela-skratov.com_admin@www.dezela-skratov.com    dezela-skratov.com_admin
admin@dezela-skratov.com    dezela-skratov.com_admin
dezela-skratov.com_admin@dezela-skratov.com    dezela-skratov.com_admin
admin@www.oblika.si    oblika.si_admin
oblika.si_admin@www.oblika.si    oblika.si_admin
admin@oblika.si    oblika.si_admin
oblika.si_admin@oblika.si    oblika.si_admin
ta@www.oblika.si    oblika.si_ta
oblika.si_ta@www.oblika.si    oblika.si_ta
ta@oblika.si    oblika.si_ta
oblika.si_ta@oblika.si    oblika.si_ta
info@www.oblika.si    oblika.si_info
oblika.si_info@www.oblika.si    oblika.si_info
info@oblika.si    oblika.si_info
oblika.si_info@oblika.si    oblika.si_info
admin@www.bss.si    bss.si_admin
bss.si_admin@www.bss.si    bss.si_admin
admin@bss.si    bss.si_admin
bss.si_admin@bss.si    bss.si_admin
info@www.bss.si    bss.si_info
bss.si_info@www.bss.si    bss.si_info
info@bss.si    bss.si_info
bss.si_info@bss.si    bss.si_info
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix & mail forwarding loop varnik Server Operation 21 9th December 2008 15:13
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 00:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.