Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd January 2007, 19:13
steveomach3ww steveomach3ww is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default Set Up Ubuntu-Server 6.10 As A Firewall/Gateway Email Problem

I have just set up the "Set Up Ubuntu-Server 6.10 As A Firewall/Gateway" and i am having problems with my email server. First off i am not completely sure how to set a user active to recieve email or send them a welcome message to set them active and when i go to webmail i get this error when i try to log in ERROR: Connection dropped by IMAP server. but then again i am guess it is because i dont have an active user to log in with. Can someone tell me the process or adding a user and seting them active to recieve email. Thank You
Reply With Quote
Sponsored Links
  #2  
Old 23rd January 2007, 19:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

If you create a new user you must send an email first to that user before you can log in with POP3 or IMAP. You can do this from an existing email account (e.g. your personal email address).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 23rd January 2007, 21:55
steveomach3ww steveomach3ww is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default Email Problems

Ok i created a new user called testemail1 and i went to my gamil account and sent him a test message and when i go into the postfix config in webmin i can see the message sitting in queue but it wont deliver it to that person. I am stumped at this point i am sure that it is somthing simple i just cant put my fingure on it.
Reply With Quote
  #4  
Old 24th January 2007, 14:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

What exactly is in the mail log when you send a mail to your server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 24th January 2007, 16:37
steveomach3ww steveomach3ww is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default Email Log

Jan 24 08:35:02 fireviper postfix/smtpd[10448]: connect from wr-out-0506.google.com[64.233.184.235]
Jan 24 08:35:02 fireviper postfix/smtpd[10448]: 65EF5E44E3: client=wr-out-0506.google.com[64.233.184.235]
Jan 24 08:35:02 fireviper postfix/cleanup[10472]: 65EF5E44E3: hold: header Received: from wr-out-0506.google.com (wr-out-0506.google.com [64.233.184.235])??by fireviper (Postfix) with ESMTP id 65EF5E44E3??for <testemail1@fireviper.mach3ww.net>; Wed, 24 Jan 2007 08:35:02 -060 from wr-out-0506.google.com[64.233.184.235]; from=<steveofire@gmail.com> to=<testemail1@fireviper.mach3ww.net> proto=ESMTP helo=<wr-out-0506.google.com>
Jan 24 08:35:02 fireviper postfix/cleanup[10472]: 65EF5E44E3: message-id=<a61a96a30701240633v55fd26e0v4d1e7dba7149061e@m ail.gmail.com>
Jan 24 08:35:32 fireviper postfix/smtpd[10448]: disconnect from wr-out-0506.google.com[64.233.184.235]
Reply With Quote
  #6  
Old 25th January 2007, 20:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

The mail log looks ok. What's the output of
Code:
netstat -tap
? Do you use Maildir or mbox format?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 27th January 2007, 05:49
steveomach3ww steveomach3ww is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is the output of that command


tcp 0 0 localhost:mysql *:* LISTEN 5188/mysqld
tcp 0 0 *:netbios-ssn *:* LISTEN 5479/smbd
tcp 0 0 *:10000 *:* LISTEN 5802/perl
tcp 0 0 *:munin *:* LISTEN 5671/munin-node
tcp 0 0 *:domain *:* LISTEN 5090/dnsmasq
tcp 0 0 *:smtp *:* LISTEN 10433/master
tcp 0 0 localhost:953 *:* LISTEN 26263/named
tcp 0 0 *:1723 *:* LISTEN 32112/pptpd
tcp 0 0 *:microsoft-ds *:* LISTEN 5479/smbd
tcp 0 0 192.168.2.1:1723 71-214-216-52.desm:xtel ESTABLISHED13924/pptpd [71.214
tcp 0 0 192.168.2.1:1723 du-106-046.omnitel:1508 ESTABLISHED13522/pptpd [207.17
tcp6 0 0 *:imaps *:* LISTEN 5323/couriertcpd
tcp6 0 0 *op3s *:* LISTEN 5361/couriertcpd
tcp6 0 0 *op3 *:* LISTEN 5340/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 5304/couriertcpd
tcp6 0 0 *:www *:* LISTEN 32307/apache2
tcp6 0 0 *:domain *:* LISTEN 5090/dnsmasq
tcp6 0 0 *:ssh *:* LISTEN 14963/sshd
tcp6 0 0 ip6-localhost:953 *:* LISTEN 26263/named
tcp6 0 0 *:https *:* LISTEN 32307/apache2
tcp6 0 0 fireviper:ssh ::ffff:192.168.2.6:2903 ESTABLISHED27926/sshd: steveo
tcp6 0 296 ::ffff:192.168.2.1%:ssh ::ffff:192.168.2.9:1755 ESTABLISHED14973/sshd: steveo
tcp6 0 0 fireviper:ssh ::ffff:192.168.2.6:1733 ESTABLISHED25943/sshd: steveo
Reply With Quote
  #8  
Old 28th January 2007, 20:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by steveomach3ww
i can see the message sitting in queue
What exactly do you see? Did you configure Postfix to deliver emails to Maildir?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 28th January 2007, 22:48
steveomach3ww steveomach3ww is offline
Junior Member
 
Join Date: Feb 2006
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Greetings I am going to post what the log shows for when i send mail to the server and also i am not for sure how to check if i have it setup to deliver mail to Maildir i belive that i do. Here is the log


Jan 28 14:47:01 fireviper postfix/smtpd[4598]: connect from ug-out-1314.google.com[66.249.92.171]
Jan 28 14:47:01 fireviper postfix/smtpd[4598]: DBC73E449E: client=ug-out-1314.google.com[66.249.92.171]
Jan 28 14:47:02 fireviper postfix/cleanup[4603]: DBC73E449E: hold: header Received: from ug-out-1314.google.com (ug-out-1314.google.com [66.249.92.171])??by fireviper.mach3ww.net (Postfix) with ESMTP id DBC73E449E??for <steveo@fireviper.mach3ww.net>; Sun, 28 Jan 2007 14:47: from ug-out-1314.google.com[66.249.92.171]; from=<steveofire@gmail.com> to=<steveo@fireviper.mach3ww.net> proto=ESMTP helo=<ug-out-1314.google.com>
Jan 28 14:47:02 fireviper postfix/cleanup[4603]: DBC73E449E: message-id=<a61a96a30701281246p5c18ac3agf1099360eeede38c@m ail.gmail.com>
Jan 28 14:47:32 fireviper postfix/smtpd[4598]: disconnect from ug-out-1314.google.com[66.249.92.171]
Reply With Quote
  #10  
Old 29th January 2007, 13:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
 
Default

What's the output of
Code:
postqueue -p
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 06:35
The Perfect Setup - Ubuntu 6.10 Server (Edgy Eft) - Page 4 carloscastaneda HOWTO-Related Questions 2 10th December 2006 23:50
Uebimiau problem for multi sites hosted in a server xmsnard Installation/Configuration 2 20th August 2006 15:08
Problem with 'CC' & 'BCC' email not being delivered. snowfly HOWTO-Related Questions 10 20th July 2006 13:36
Ubuntu 5.04 Server Noob Problem jugo23 Installation/Configuration 1 14th October 2005 10:23


All times are GMT +2. The time now is 07:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.