Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th January 2007, 15:59
mccyberix mccyberix is offline
Member
 
Join Date: Aug 2006
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mailbox inaccessible!

hi, my ISPConfig is actualy working wery fine but sometimes when I set up a new domain and add a mailbox to it, it will not be accessible. When I delete the whole domain and set it up again it works fine (this behavior affects only the mailbox not the webspace). Is this a known issue and is there a posibility to fix it without deleting the whole domain? If not I will be happy with an alternative workaround which causes a new question, when I delete a domain with the user id "web13_" and add the same domain again it gets the new id "web14_", so is it possible to assign the same id again?
thank you in advance, and have a nice day
Reply With Quote
Sponsored Links
  #2  
Old 13th January 2007, 16:02
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Do you sent an initial welcome message to the just created user / mailbox? When a client connects, the Maildir structure is present, because it's created by Postfix with the 1st message.
Reply With Quote
  #3  
Old 13th January 2007, 16:36
mccyberix mccyberix is offline
Member
 
Join Date: Aug 2006
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I know what you mean, i had to do this before I use the ISPConfig but since I install ISPC I never had to send an initial welcomemessage, however I tryed to send one but I get an "540 Relay access denied (in reply to RCPT TO command)" Error, I also tried to send one directly with telnet then it says that the message has been qued but it never arrives to the Maildir, in my mail.log I found entrys which say the mail is bounced and it loops back to it self. My DNS records are also ok. So what else can cause the issue?
Reply With Quote
  #4  
Old 13th January 2007, 17:22
mccyberix mccyberix is offline
Member
 
Join Date: Aug 2006
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

One more I have to say, I am able to login via IMAP (thunderbird) and send mail out but when I reply to that mail I get the folowing error:
<xxx@xxx.xx>: host xxx.xxx.xx[xx.xx.xx.xxx]
said: 554 <xxx@xxx.xx>: Relay access denied (in reply to
RCPT TO command)
Reply With Quote
  #5  
Old 13th January 2007, 19:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please enable SMTP authentication in thunderbird.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 18th January 2007, 10:03
mccyberix mccyberix is offline
Member
 
Join Date: Aug 2006
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Till, but this is definitly not the problem, it doesn't matter from where I try to send the mail, it never arrives. The server allways replies with the same error, I have several domains running on the same server and they all working fine except the one although they have the same settings.
Reply With Quote
  #7  
Old 18th January 2007, 10:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Is the domain listed in /etc/postfix/local-host.names?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 19th January 2007, 17:49
mccyberix mccyberix is offline
Member
 
Join Date: Aug 2006
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes it is, thats realy a strange behavior I have no clue where the problem is
Reply With Quote
  #9  
Old 20th January 2007, 18:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's in /etc/postfix/main.cf (please strip out the comments)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 21st January 2007, 22:42
mccyberix mccyberix is offline
Member
 
Join Date: Aug 2006
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

PHP Code:
smtpd_banner $myhostname ESMTP $mail_name (Debian/GNU)
biff no

append_dot_mydomain 
no


myhostname 
server.mydomain.com (replaced)
alias_maps hash:/etc/aliases
alias_database 
hash:/etc/aliases
myorigin 
= /etc/mailname
relayhost 

mynetworks 127.0.0.0/8
mailbox_command 

mailbox_size_limit 0
recipient_delimiter 
= +
inet_interfaces all
smtpd_sasl_local_domain 

smtpd_sasl_auth_enable yes
smtpd_sasl_security_options 
noanonymous
broken_sasl_auth_clients 
yes
smtpd_recipient_restrictions 
permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only 
no
smtp_use_tls 
yes
smtpd_use_tls 
yes
smtp_tls_note_starttls_offer 
yes
smtpd_tls_key_file 
= /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file 
= /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile 
= /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel 
1
smtpd_tls_received_header 
yes
smtpd_tls_session_cache_timeout 
3600s
tls_random_source 
dev:/dev/urandom
home_mailbox 
Maildir/

virtual_maps hash:/etc/postfix/virtusertable

mydestination 
= /etc/postfix/local-host-names 
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix mailbox not exist from Internet mhagelstrom Server Operation 3 18th November 2006 14:46
big truble with Mailbox mccyberix General 4 25th August 2006 17:13
Maildir And Mailbox pinguingilo Server Operation 1 30th July 2006 13:53
Mailbox size policy & Cyrus oliver.blaha Developers' Forum 16 1st May 2006 13:30
Reroute spam to different mailbox? farao Installation/Configuration 5 28th September 2005 14:52


All times are GMT +2. The time now is 02:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.