Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Technical

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 30th November 2007, 03:20
mtaylor314 mtaylor314 is offline
Junior Member
 
Join Date: Nov 2007
Location: Cleves, OH
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to mtaylor314
Default web developer moving to linux

been a web developer for about 7 months and been getting more and more frustrated with windows. I have set up a LAMP system to develop some php web sites. No issues there. Using apache for Windows I can set up a web site at any directory as long as DocumentRoot was pointed there. I would change my lmhosts file for the servername and I'd be set. My problem is I need root privileges to edit anything under /var/www, which I prefer not to edit things with those privileges, and if I set my DocumentRoot to a directory in my user's folder, firefox says I don't have access to view "/". What is the best way to develop web sites with this set up?
__________________
Toshiba Satellite A135-S4427 - Dual booting Linux Mint 4.0 and Windows Vista Home Premium - Processor: Intel Core Duo T2250 (1.73 GHz/2MB L2 Cache) - Hard Drive: 120 GB SATA @ 5400RPM - Graphics: Intel Graphics Media Accelerator 950, Up To 224 MB Shared - RAM: 1GB DDR2 SDRAM @533 MHz (2x512MB) - Optical Drive: DVD SuperMulti Drive (CD/DVD burner) - Wireless: Intel PRO/Wireless 3945 802.11 a/b/g
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Visual Web developer 2005 and Linux willebanks Programming/Scripts 2 16th May 2008 18:02
get thousands of "Mailsize" mails from own server torusturtle Installation/Configuration 20 24th December 2006 15:51
not receiving mail (postfix) lathrodectus General 7 28th June 2006 15:12
Problems installing NForce4 sound drivers Wraithfire Installation/Configuration 21 16th April 2006 18:30
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 13:59


All times are GMT +2. The time now is 17:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.