#1  
Old 18th November 2007, 16:11
40esp 40esp is offline
Member
 
Join Date: Jun 2007
Posts: 50
Thanks: 5
Thanked 2 Times in 2 Posts
Default Shared IP

Whenever I create a subdomain "or simply setting the hostname" I get a shared ip error.

This is my setup

I register my domains through 1and1

I set them all to the same IP address my server uses

I created two subdomains on 1and1

The main domain site in ispconfig works which is jaikobcreate.com
When I go to create new site -- i set the hostname to the subdomain part I want then the main domain name, and I have it create the records for me in dns.


I am behind a router. but I am using different local IP addresses

10.129.0.2 -- local
10.129.0.3 -- local
10.129.0.4 -- local

And my WAN address (which I used for my domains) id 71.13.92.xxx

so in retrospect I have this setup:

1and1 Domains Registered:

jaikobcreate.com 71.13.92.xxx
xxx.jaikobcreate.com 71.13.92.xxx

Router - WAN - 71.13.92.xxx LAN 10.129.0.xxx
3 static LAN addresses
10.129.0.2
10.129.0.3
10.129.0.4

my linux server box had virtual network interfaces with the local static IP's configured into it.

ISPConfig see's the IP addresses
When I make a new site in ispconfig I use one of the 3 local IP's for each domain i have. I never use 1 IP for more than 1 domain.
When I want to make a subdomained host I make a new site, and change the hostname to the first part of the subdomain.

then i fill out everything else.

my main DNS record for jaikobcreate.com is set for 10.129.0.2
the A record - www is set to 10.129.0.2
in DNS the A records are set for the hostname of the subdomain, but they are a different IP address then the main record.

why is it giving me a shared IP error, when indeed its not a shared IP?

Last edited by 40esp; 18th November 2007 at 16:14.
Reply With Quote
Sponsored Links
  #2  
Old 19th November 2007, 10:34
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

Websites in ISPConfig can only be accessed by domain and not by IP. You can have as many domains on one IP as you like. You will have to select the IP in ISPConfig for the website where you forwarded port 80 on your router to and no other IP. If you select any other IP, you will get the shared IP message.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th November 2007, 00:43
40esp 40esp is offline
Member
 
Join Date: Jun 2007
Posts: 50
Thanks: 5
Thanked 2 Times in 2 Posts
Default

this is the problem.

when i enter my domain name jaikobcreate.com

i get my website

but when i access bpa.jaikobcreate.com i get a shared IP error

domain name jaikobcreate.com is using 10.129.0.2 and it is in the A record(www).
this works

subdomain bpa.jaikobcreate.com doesnt work

it is under the jaikobcreate.com dns entry, and has an A Record of 10.129.0.3 (hostname bpa)

i need to have two sites with a different IP so that i can get ssl on both of them

i made sure my router forwards by setting a costom firewall rule allowing all of my ip addresses configured with my server, to access all ports.

idk whats wrong, and ive searched this forums for help, but find none.

configured in my router is one static ip 71.13.92.13x
my server uses the internal ip 10.129.0.2 as eth0 and the hostname is 71-13-92-13x.static.bycy.mi.charter.com
eth0:x is set to retrieve the local ips i need for each site.
Reply With Quote
  #4  
Old 20th November 2007, 09:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

create a co-domain in the website jaikobcreate.com where you set

hostname: bpa
domain: jaikobcreate.com

If this shall be a independant website, create a website with the same IP address then you used for jaikobcreate.com with:

hostname: bpa
domain: jaikobcreate.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th November 2007, 12:10
40esp 40esp is offline
Member
 
Join Date: Jun 2007
Posts: 50
Thanks: 5
Thanked 2 Times in 2 Posts
Default

I need ssl support on both sites though that is the problem
Reply With Quote
  #6  
Old 20th November 2007, 12:19
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
 
Default

Ok, in this case you need 2 external IP addresses and a router that supports 2 external IP addresses. Or yoiu need a wlidcard SSL certificate and then add bpa.jaikobcreate.com as co-domain to the site jaikobcreate.com and redirect it to a subdirectory with apache rewrite rules.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whats the simplest way to have a shared folder local and remote access steve1084 HOWTO-Related Questions 5 12th September 2007 04:03
newbie: shared ip amdserver General 8 25th March 2007 17:13
Totally Confused DNS & Shared IP Hawker Installation/Configuration 7 2nd March 2007 08:33
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
How do you set up shared hosting? PorkFat Installation/Configuration 3 29th December 2005 12:11


All times are GMT +2. The time now is 11:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.