Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 6th August 2006, 21:00
alex916 alex916 is offline
Member
 
Join Date: Dec 2005
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Great! Now it's perfect and i can send email using m isp-config server also if another isp block port 25.

Thanks
Reply With Quote
Sponsored Links
  #12  
Old 15th November 2007, 01:29
gwa7 gwa7 is offline
Member
 
Join Date: Jan 2007
Posts: 34
Thanks: 2
Thanked 10 Times in 6 Posts
Default Having the same problem

I'm having the same problem and getting the same error message, but the fix does not work for me. Any ideas?
Reply With Quote
  #13  
Old 15th November 2007, 05:01
gwa7 gwa7 is offline
Member
 
Join Date: Jan 2007
Posts: 34
Thanks: 2
Thanked 10 Times in 6 Posts
Smile It's working

This is what worked for me. I had to make both lines match:

smtp inet n - n - - smtpd
587 inet n - n - - smtpd

(I actually used a different port number than 587)

One more thing for Evolution users:
If you change the default smtp port, add the port to the end of your mail server like this: mail.yourserver.com:587
Reply With Quote
The Following 3 Users Say Thank You to gwa7 For This Useful Post:
alvedaro (3rd April 2008), bizna (29th August 2010), falko (15th November 2007)
  #14  
Old 10th December 2007, 18:16
Cools Cools is offline
Junior Member
 
Join Date: Apr 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks to you guys i have the company email working..

as they are so tight on security. i cant use port 25 properly over the vpn so i now have 587 doing the same job.

Keep up the good work guys.




----------------------------------------------------
i bookmark pages incase i become thick one day!!
Reply With Quote
  #15  
Old 12th February 2008, 01:44
gwa7 gwa7 is offline
Member
 
Join Date: Jan 2007
Posts: 34
Thanks: 2
Thanked 10 Times in 6 Posts
Default TLS working but not SSL on port 587

As I stated earlier, these settings worked for me:

smtp inet n - n - - smtpd
587 inet n - n - - smtpd

TLS encryption works on the new port 587. It also works without encryption on this port.
SSL encryption works on port 25.
However, when I try to send an email to my server with SSL on port 587, it just sits in the outbox. Any ideas on what I need to change to make this work?

I appreciate your help and thanks again for ISPconfig!

Gary

Last edited by gwa7; 12th February 2008 at 02:27.
Reply With Quote
  #16  
Old 12th February 2008, 20:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

What's in /etc/postfix/master.cf? Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 12th February 2008, 20:45
gwa7 gwa7 is offline
Member
 
Join Date: Jan 2007
Posts: 34
Thanks: 2
Thanked 10 Times in 6 Posts
Default

Thanks for your quick reply. I am actually using port 2525 instead of 587.
Here is what you requested:

What's in /etc/postfix/master.cf:
Quote:
# Postfix master process configuration file. For details on the format
# of the file, see the Postfix master(5) manual page.
#
# ================================================== ========================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ================================================== ========================
smtp inet n - n - - smtpd
2525 inet n - n - - smtpd

#submission inet n - n - - smtpd
# -o smtpd_etrn_restrictions=reject
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
#smtps inet n - n - - smtpd -o smtpd_tls_wrappermode=yes
# -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n - n - - smtpd
# -o smtpd_etrn_restrictions=reject
# -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628 inet n - n - - qmqpd
pickup fifo n - n 60 1 pickup
cleanup unix n - n - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - n 300 1 oqmgr
tlsmgr unix - - n 1000? 1 tlsmgr
rewrite unix - - n - - trivial-rewrite
bounce unix - - n - 0 bounce
defer unix - - n - 0 bounce
trace unix - - n - 0 bounce
verify unix - - n - 1 verify
flush unix n - n 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - n - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - n - - smtp
-o fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - n - - showq
error unix - - n - - error
discard unix - - n - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - n - - lmtp
anvil unix - - n - 1 anvil
#localhost:10025 inet n - n - - smtpd -o content_filter=
scache unix - - n - 1 scache
#
# ================================================== ==================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ================================================== ==================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus unix - n n - - pipe
user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
procmail unix - n n - - pipe
flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
# 26 inet n - - - - smtpd
# 587 inet n - n - - smtpdmail:/etc/postfix #

From mail log:
Quote:
Feb 12 13:37:57 mail postfix/smtpd[30309]: connect from r74-193-117-236.suspcmta01.slsptx.tl.dh.suddenlink.net[74.193.117.236]
Feb 12 13:40:41 mail postfix/smtpd[30175]: timeout after CONNECT from r74-193-117-236.suspcmta01.slsptx.tl.dh.suddenlink.net[74.193.117.236]
Feb 12 13:40:41 mail postfix/smtpd[30175]: disconnect from r74-193-117-236.suspcmta01.slsptx.tl.dh.suddenlink.net[74.193.117.236]
Reply With Quote
  #18  
Old 31st March 2008, 13:25
blocker blocker is offline
Senior Member
 
Join Date: Mar 2008
Posts: 177
Thanks: 9
Thanked 4 Times in 4 Posts
Default

Hi All,

it worked for me perfectly, however i want to use my ispconfig server as alternative smtp server for domains that are not hosted on the ispconfig server. I add the domain and create the desired users that should be able to use the ispconfig alternative smtp server, everything works perfect, only 1 thing do not - sending mails from that domain to itself. The ispconfig handles these mails internal. I have set "External Mailserver" for that domain but that didnt helped at all. I also deleted the domain from /etc/postfix/local-host-names but after running /root/ispconfig/php/bin/php /root/ispconfig/scripts/writeconf.php this domain is automaticaly added in /etc/postfix/local-host-names. What can i do to achieve my target?
N/B I hope there will be an "ISPconfig way" doing this because i want ppl that do nnot have access to the server but only to ispconfig admin interface to be able to add domains and users which will be able to use the alternative SMTP port...

Thanks in advance!!!!!
Reply With Quote
  #19  
Old 1st April 2008, 17:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Quote:
Originally Posted by blocker
I have set "External Mailserver" for that domain but that didnt helped at all.
Did you do this only for the main FQDN (e.g. www.example.com), or also for the Co-Domains? Each Co-Domain has its own Options tab where you can select "External Mailserver".
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 1st April 2008, 20:10
blocker blocker is offline
Senior Member
 
Join Date: Mar 2008
Posts: 177
Thanks: 9
Thanked 4 Times in 4 Posts
 
Default

Quote:
Originally Posted by falko
Did you do this only for the main FQDN (e.g. www.example.com), or also for the Co-Domains? Each Co-Domain has its own Options tab where you can select "External Mailserver".
only for FQDN, i have no subdomains for the test domain... but postfix tries to deliver locally...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Fedora 4 TPS mail problem Hagforce HOWTO-Related Questions 13 10th February 2010 18:23
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
smtp authentication (postfix and courier imap) chrno Installation/Configuration 1 8th May 2006 21:22
postfix courier not running in ssl mode? shadowsa Server Operation 4 19th December 2005 13:20


All times are GMT +2. The time now is 03:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.