Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 31st October 2007, 20:39
kvdd kvdd is offline
Junior Member
 
Join Date: Oct 2007
Posts: 11
Thanks: 3
Thanked 0 Times in 0 Posts
Default Users can't acces their folders with Web-FTP

What I have done:

- Create a user called Klant1 and give them the normal rights, no Shell Acces, limited space and so on. This is not working!
- Create a user called Klant3 and give them all the rights including Shell Acces and anonymous acces. Not working too!
- Find this and this topic on this forum, but that is not exacly my problem (the first) and the second didn't solve the problem.

I have looked in my proftpd.conf, but everything is looking good in my eyes:
Code:
# This is a basic ProFTPD configuration file (rename it to 
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName			"ProFTPD Default Installation"
ServerType			standalone
DefaultServer			on

#Added for security reasons:
DefaultRoot ~
IdentLookups off
ServerIdent on "FTP Server ready."

# Port 21 is the standard FTP port.
Port				21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask				022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances			30

# Set the user and group under which the server will run.
User				nobody
Group				nobody

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
DefaultRoot ~

# Normally, we want files to be overwriteable.
AllowOverwrite		on

# Bar use of SITE CHMOD by default
<Limit SITE_CHMOD>
  DenyAll
</Limit>

# A basic anonymous configuration, no upload directories.  If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
<Anonymous ~ftp>
  User				ftp
  Group				ftp

  # We want clients to be able to login with "anonymous" as well as "ftp"
  UserAlias			anonymous ftp

  # Limit the maximum number of anonymous logins
  MaxClients			10

  # We want 'welcome.msg' displayed at login, and '.message' displayed
  # in each newly chdired directory.
  DisplayLogin			welcome.msg
  DisplayFirstChdir		.message

  # Limit WRITE everywhere in the anonymous chroot
  <Limit WRITE>
    DenyAll
  </Limit>
</Anonymous>


Include /etc/proftpd_ispconfig.conf
I have following the Perfect Setup for CentOS 5, and including some security options. (from line 10-13 in the code shown above)

I hope someone knows the problem, and thanks in advance!

[edit] And with an FTP program it doesn't work too [/edit]

Last edited by kvdd; 31st October 2007 at 21:56.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP user can access whole web folders Y2K.bug Installation/Configuration 2 16th February 2007 19:14
Junk mail and spamassassin... sthompson Installation/Configuration 4 27th December 2006 16:11
FTP Error joshabts Installation/Configuration 3 4th November 2006 16:19
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 08:03
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 17:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.