#1  
Old 26th October 2007, 17:47
lain27 lain27 is offline
Junior Member
 
Join Date: Oct 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default ispconfig & google apps & ddns

hi, first of all i want to thank you all for the great ispconfig, i've tried a few and ispconfig was the best, but i've got a few questions:

i've followed the great guide perfect setup on debian etch, setup ispconfig, and tried to setup google apps standard for my host, the problem is everytime i try to access any google apps subdomain i get shared ip page. Dig'in my host gave me this :
Code:
; <<>> DiG 9.3.4 <<>> myhost (changed)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9230
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;;myhost.           IN      A

;; ANSWER SECTION:
myhost.    60      IN      A       85.240.43.127

;; Query time: 201 msec
;; SERVER: 212.55.154.174#53(212.55.154.174)
;; WHEN: Fri Oct 26 15:35:30 2007
;; MSG SIZE  rcvd: 53
and dig'in mail.myhost as configured in google apps mail i get this:
Code:
; <<>> DiG 9.3.4 <<>> mail.myhost
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28681
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mail.myhost.      IN      A

;; ANSWER SECTION:
mail.myhost. 60    IN      CNAME   myhost.
myhost.    60      IN      A       85.240.43.127

;; Query time: 206 msec
;; SERVER: 212.55.154.174#53(212.55.154.174)
;; WHEN: Fri Oct 26 15:38:13 2007
;; MSG SIZE  rcvd: 72
dig'in my google apps start page give me this:

Code:
; <<>> DiG 9.3.4 <<>> go.myhost
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1176
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;go.myhost.                IN      A

;; ANSWER SECTION:
go.myhost. 60      IN      CNAME   myhost.
myhost.    60      IN      A       85.240.43.127

;; Query time: 140 msec
;; SERVER: 212.55.154.174#53(212.55.154.174)
;; WHEN: Fri Oct 26 15:40:28 2007
;; MSG SIZE  rcvd: 70

my vhosts_ispconfig.conf file:
Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 192.168.8.2:80
<VirtualHost 192.168.8.2:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: gangf.kicks-ass.org:80
######################################
#
#
<VirtualHost 192.168.8.2:80>
ServerName myhost:80
ServerAdmin webmaster@myhost
DocumentRoot /var/www/web1/web
ServerAlias myhost
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Alias /error/ "/var/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
</VirtualHost>
#
only google apps pages gave me shared ip, another thing is that i've got dynamic dns with free service from dyndns, as i'm updating with ddclient (ddclient is returning some error and messes my wildcard settings in dyndns, anyone got the same problem?)

thanks, Afonso

regards from Portugal
Reply With Quote
Sponsored Links
  #2  
Old 27th October 2007, 17:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

What's the output of
Code:
ifconfig
?

(BTW, if you want to use mail.myhost for emails, then mail.myhost must be an A record, not a CNAME. You cannot point MX records to CNAMEs.)
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th October 2007, 23:10
lain27 lain27 is offline
Junior Member
 
Join Date: Oct 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ifconfig wont help this case because i'm getting the shared ip from another internet connection...

ifconfig on the server:
Code:
eth0      Link encap:Ethernet  HWaddr 00:00:E8:EA:73:95  
          inet addr:192.168.8.2  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::200:e8ff:feea:7395/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:63005 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57559 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5773317 (5.5 MiB)  TX bytes:8742648 (8.3 MiB)
          Interrupt:11 Base address:0xe800
my mail.myhost needs to be a cname because it points to a webmail page and not a mail server... (it's the alternate url for google apps mail)...

cheers, Afonso
Reply With Quote
  #4  
Old 29th October 2007, 17:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Looks ok.
Do you use http://myhost in your browser, or http://something.myhost?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up Google Apps for my Domain meekish Installation/Configuration 11 15th April 2009 18:41
Confused about purpose of ISPConfig swpr General 3 8th July 2006 09:49
ISPConfig Install Error badenzer Installation/Configuration 2 23rd June 2006 01:20
42goISP vs. ISPConfig nveid General 1 16th January 2006 10:07
ISP-Ubuntu breezy ispconfig dns email e-mail working finally yellowjelly HOWTO-Related Questions 0 19th November 2005 21:30


All times are GMT +2. The time now is 05:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.