Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th October 2007, 01:02
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default mail delivery issues

After upgrading to the latest ISPConfig version, I've noticed a problem appearing, at least for me. When emailing to POP3 accounts on the box, there are problems having the mail delivered. Here's the email auto-response from one of the SMTP servers that tried to deliver to the server running ISPConfig. Let me know what could be done to try and solve this.



This report relates to a message you sent with the following header fields:

Message-id: <e88cfdd838a21.471bc72f@uark.edu>
Date: Sun, 21 Oct 2007 21:39:59 -0500
From: "DG" <bsregistersATderekgordon.com>
To: "AS" <gradrelationsATuaphigam.com>
Subject: Re: FW: Phi Alpha - Graduate Chair

Your message has been enqueued and undeliverable for 1 day
to the following recipients:

Recipient address: gradrelationsATuaphigam.com
Reason: unable to deliver this message after 1 day


Delivery attempt history for your mail:

Mon, 22 Oct 2007 22:45:36 -0500 (CDT)
Failed MX lookup; try again later

Mon, 22 Oct 2007 14:45:30 -0500 (CDT)
Failed MX lookup; try again later

Mon, 22 Oct 2007 10:44:30 -0500 (CDT)
Failed MX lookup; try again later

Mon, 22 Oct 2007 06:43:41 -0500 (CDT)
Failed MX lookup; try again later

Mon, 22 Oct 2007 02:42:41 -0500 (CDT)
Failed MX lookup; try again later

Mon, 22 Oct 2007 00:42:19 -0500 (CDT)
Failed MX lookup; try again later

Sun, 21 Oct 2007 22:41:19 -0500 (CDT)
Failed MX lookup; try again later

Sun, 21 Oct 2007 21:40:39 -0500 (CDT)
Failed MX lookup; try again later

The mail system will continue to try to deliver your message
for an additional 4 days.


Any advice? Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 24th October 2007, 11:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Please make sure that a MX record for the domain uaphigam.com exists.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th October 2007, 22:37
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

Yes, the MX record points to the main domain on the server so it does exist.

From the Named File:
www MX 10 www.inter5.org.
mail MX 10 mail.uaphigam.com.

uaphigam.com. A 207.150.163.134
www A 207.150.163.134
mail A 207.150.163.134
Reply With Quote
  #4  
Old 25th October 2007, 10:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Please post the output of:

dig MX uaphigam.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th October 2007, 18:36
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

dingle@its:/home/dingle# dig MX uaphigam.com

; <<>> DiG 9.2.4 <<>> MX uaphigam.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11886
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;uaphigam.com. IN MX

;; AUTHORITY SECTION:
uaphigam.com. 86400 IN SOA 207.150.163.130. admin.uaphigam.com. 2007102402 28800 7200 604800 86400

;; Query time: 38 msec
;; SERVER: 207.150.163.131#53(207.150.163.131)
;; WHEN: Thu Oct 25 12:35:53 2007
;; MSG SIZE rcvd: 87
Reply With Quote
  #6  
Old 26th October 2007, 05:21
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

DIG still doesn't resolve anything that I would say worthwhile. However, I changed a couple lines in the NAMED record and it seems to be working. I tried two emails and both came through...

;; QUESTION SECTION:
;uaphigam.com. IN MX

NAMED change:
www MX 10 www.inter5.org.
mail MX 10 mail.uaphigam.com.
-to-
uaphigam.com. MX 10 mail.inter5.org.
Reply With Quote
  #7  
Old 26th October 2007, 11:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
 
Default

If you create a MX record, you will have to leave the hostname field empty. Sorry, I did not recognized that in your first post that you had mail and www in the mx hostname field. If you put e.g. mail in the hostname field, the MX record will be for emails in the format ....@mail.uaphigam.com and not ....@uaphigam.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix & mail forwarding loop varnik Server Operation 21 9th December 2008 15:13
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
postfix-tls sasl2 mysql courier-authmysql gabrix Server Operation 4 12th January 2007 22:09
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 06:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.