Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 22nd October 2007, 13:18
erebus erebus is offline
Member
 
Join Date: Sep 2007
Posts: 63
Thanks: 10
Thanked 9 Times in 9 Posts
Default Centos 4.5, CentosPlus and ISPConfig

Hello,

As I migrate my old customers to a new server with ISPConfig these days, I found out that Centos 4.5 is stick with MySQL4 and PHP4, while I needed the new 5 version for both. So I took the great decision to upgrade my perfect setup using the centosplus repo.

So here is the yum.log of what happened during the upgrade:

Code:
Oct 22 11:42:13 Installed: perl.i386 4:5.8.8-4.el4s1
Oct 22 11:42:13 Installed: php-common.i386 5.1.6-3.el4s1.7
Oct 22 11:42:16 Installed: mysql-libs.i386 5.0.48-1.el4.centos
Oct 22 11:42:17 Installed: mysqlclient14.i386 4.1.22-1.el4s1.1
Oct 22 11:42:17 Updated: unixODBC.i386 2.2.12-1.el4s1.1
Oct 22 11:42:19 Installed: httpd.i386 2.0.59-1.el4s1.7.el4.centos
Oct 22 11:42:20 Installed: php-pdo.i386 5.1.6-3.el4s1.7
Oct 22 11:42:20 Installed: autoconf.noarch 2.59-5
Oct 22 11:42:21 Updated: postgresql-libs.i386 8.1.9-1.el4s1.1
Oct 22 11:42:25 Installed: postgresql.i386 8.1.9-1.el4s1.1
Oct 22 11:42:26 Installed: automake.noarch 1.9.2-3
Oct 22 11:42:27 Installed: php-cli.i386 5.1.6-3.el4s1.7
Oct 22 11:42:27 Updated: php.i386 5.1.6-3.el4s1.7
Oct 22 11:42:28 Updated: php-pear.noarch 1:1.4.11-1.el4s1.1
Oct 22 11:42:28 Installed: perl-Compress-Zlib.i386 1.42-1.el4
Oct 22 11:42:29 Updated: perl-libwww-perl.noarch 5.805-1.1.1
Oct 22 11:42:30 Updated: perl-DBI.i386 1.54-1.el4s1
Oct 22 11:42:30 Updated: perl-DBD-MySQL.i386 3.0008-1.el4.centos
Oct 22 11:42:32 Updated: mysql.i386 5.0.48-1.el4.centos
Oct 22 11:42:32 Installed: postgresqlclient7.i386 7.4.17-1.el4s1.1
Oct 22 11:42:36 Updated: postfix.i386 2:2.2.10-1.1.el4.centos.mysql_pgsql.plus
Oct 22 11:42:36 Updated: php-ldap.i386 5.1.6-3.el4s1.7
Oct 22 11:42:37 Updated: php-mysql.i386 5.1.6-3.el4s1.7
Oct 22 11:42:38 Updated: php-devel.i386 5.1.6-3.el4s1.7
Oct 22 11:42:40 Updated: mysql-server.i386 5.0.48-1.el4.centos
Oct 22 11:42:40 Updated: php-xmlrpc.i386 5.1.6-3.el4s1.7
Oct 22 11:42:41 Updated: php-imap.i386 5.1.6-3.el4s1.7
Oct 22 11:42:42 Updated: mysql-devel.i386 5.0.48-1.el4.centos
Oct 22 11:42:42 Updated: php-gd.i386 5.1.6-3.el4s1.7
Oct 22 11:42:53 Installed: kernel.i686 2.6.9-55.0.9.plus.c4
Oct 22 11:42:54 Updated: php-odbc.i386 5.1.6-3.el4s1.7
Oct 22 11:42:57 Erased: perl-Filter
Oct 22 11:42:59 Erased: httpd-suexec
I didn't have any major problems after the upgrade, however I have some questions and I would like your help to clarify things:

1) After the upgrade, php.ini, php.conf and httpd.conf were replaced by new versions. What was seemed to be missing from httpd.conf only, was the ISPConfig vhost entries at the end. I restarted both the httpd and ispconfig and I didn't see any change to the httpd.conf - so I added these entries at the end, taken from the old conf file. Is this normal? Should I had to wait for ISPConfig to do these changes after some time (or after an update)?

2) perl-Filter and httpd-suexec were erased automatically after the upgrade. Is this normal?

3) Now when I login in phpmyadmin, it shows this message:

Code:
Your PHP MySQL library version 4.1.22 differs from your MySQL server version 5.0.48. This may cause unpredictable behavior.
Although I can't see any 'unpredictable behaviour' till now, I want to ask if this is normal too, and if somebody knows how to fix it...

4) How can I add the centosplus repo to be included by default for every yum updates in the future (meaning without the need for the command line switch --enablerepo=centosplus).

5) [offtopic]Running crontab -l shows all the crontabs added by ISPConfig (like webalizer). In /etc/cron.daily however, I have another webalizer script, named 00webalizer, chmoded 755. Is this needed too? I don't know if it runs though... In the same dir, there is another script named 00-logwatch which runs normally...[/offtopic]

Thank you very much in advance for helping me on these issues.

Best regards,
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.