Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 21st October 2007, 17:05
wxman wxman is offline
Senior Member
 
Join Date: May 2007
Posts: 189
Thanks: 11
Thanked 2 Times in 2 Posts
Default Segmentation fault errors after BIND editing

Hi All,

It seems that I've botched up something on my new server. I had most of it working, and I was just tweaking the DNS settings. After I did a bind restart I saw my SMTP wasn't working. The errors were mainly showing that it couldn't get any updates from clamav. I did another restart of bind, and got:

Code:
root@server1:/home/tom# /etc/init.d/bind9 restart
 * Stopping domain name service...                                       [ ok ]
/etc/init.d/bind9: line 17:  5652 Segmentation fault      sleep 2
 * Starting domain name service...                                                                                                                           /etc/init.d/bind9: line 17:  5818 Segmentation fault      mkdir -p /var/run/bind                                                                             /run
/etc/init.d/bind9: line 17:  5822 Segmentation fault      chmod 775 /var/run/bin                                                                             d/run
                                                                         [ ok ]
I did some research, and found others saying that they had similar problems that were fixed by making the bind directory world readable. The permissions are set like this now:

Code:
root@server1:/var/run# ls -al
total 40
drwxr-xr-x 13 root   root    440 2007-10-21 06:25 .
drwxr-xr-x 14 root   root   4096 2007-10-03 20:17 ..
drwxr-xr-x  2 root   root     60 2007-10-21 06:25 apache2
-rw-r--r--  1 root   root      5 2007-10-21 06:25 apache2.pid
-rw-r--r--  1 root   root      5 2007-10-20 10:49 atd.pid
drwxr-xr-x  3 root   root     60 2007-10-20 10:49 bind
drwxr-xr-x  2 root   root    140 2007-10-21 06:25 console
drwxr-xr-x  4 daemon daemon  240 2007-10-20 10:49 courier
-rw-r--r--  1 root   root      5 2007-10-20 10:49 crond.pid
----------  1 root   root      0 2007-10-20 10:49 crond.reboot
drwxr-xr-x  2 klog   klog    100 2007-10-20 10:49 klogd
-rw-r--r--  1 root   root      5 2007-10-20 10:49 mdadm.pid
drwxr-xr-x  2 mysql  root     80 2007-10-20 10:49 mysqld
drwxr-xr-x  2 root   root     60 2007-10-21 10:12 network
drwxr-xr-x  2 root   root     80 2007-10-20 23:59 proftpd
-rw-r--r--  1 root   root      6 2007-10-20 23:59 proftpd.pid
drwx--x---  2 root   sasl     40 2007-10-20 10:49 saslauthd
drwxr-xr-x  2 root   root     40 2007-10-20 10:49 sshd
-rw-r--r--  1 root   root      5 2007-10-20 10:49 sshd.pid
drwx------  3 root   root     60 2007-10-20 15:36 sudo
-rw-r--r--  1 root   root      6 2007-10-21 06:47 syslogd.pid
-rw-rw-r--  1 root   utmp   4992 2007-10-21 10:48 utmp

root@server1:/var/run/bind# ls -al
total 0
drwxr-xr-x  3 root root  60 2007-10-20 10:49 .
drwxr-xr-x 13 root root 440 2007-10-21 06:25 ..
drwxrwxr-x  2 root bind  40 2007-10-20 22:13 run
Now if I try to use CHMOD on these directories, all I get is "Segmentation fault". The only other thing I did was use ISPConfig to add another domain to test with. Both of my test sites work when I try to access them through the web, I can still log into ISPConfig, and SSH just fine.
I just can't find what I messed up this time?
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache exit signal Segmentation fault (11) - PHP - Blank page Salvis Server Operation 12 16th September 2011 16:11
ISPConfig and BIND on Debian sarge (rfc1912 : failed on zonecheck) arnaud Installation/Configuration 13 6th March 2007 12:40
Segmentation fault with /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf. AlecWeb Installation/Configuration 5 28th July 2006 20:25
Bind-Chroot-Howto (Debian) spaz HOWTO-Related Questions 5 9th March 2006 14:50
PHP version... ctroyp Installation/Configuration 102 10th November 2005 13:24


All times are GMT +2. The time now is 07:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.