Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 14th October 2007, 11:46
barney.parker barney.parker is offline
Junior Member
 
Join Date: Jun 2007
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ubuntu / Postfix problem - [newbie]

Hi,

I have an ubuntu server, set up with postfix for virtual mail users as per the perfect setup -postfix / mysql etc....

it has been working fine for several months, but a few days ago it gave up during an upgrade!

At this point i would like to point out i am a complete linux newbie, so please give any answers like you're talking to a child please!!! :-)

OK, so i did an apt-get update, then an apt-get upgrade, but got an error with mysql not stopping and the initscript failing.

I went to check out the log files, but all i got when i tried to nano mysql.log was a segmentation fault!

i've googled around a bit and found that it could be A) a memory error, B) a disk error or C) a libraby corruption.

my problem is i can't seem to find anythihng to help! Apparently with RPM you can verify packages, when you find the offendor, you can re-install it and things should go back to normal.

unfortunately i can't seem to find the same for Ubuntu/debian....

I know there's a memory test on the installer CD, but right now i don't have access to the machine, except through SSH...any thoughts there?

I also can't seem to find a way fo performing a disk check...

The machine is pretty old, but runs in an air conditioned server room. it could well be a memory problem....


now to postfix: when i send a mail to the server all seems fine. I tried using telnet, and postfix told me the mail had been queued, but it never appeared in the virtual mailbox folder (/home/vmail/[domain]/[user]/cur (or any other folder in this tree)

i can't view log files because of this segmentation fault, and i have no idea how to use any other text editor for the job, but i guess there might be some answers in there....


does anyone have any ideas on what i can do here?

I can get access to the machine in the next few days, but i'd like to have a few firm ideas on what i can try as i will be on site for only a few hours....


thanks in advance, any help will be gratefully accepted!!!
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Problem: Cant send mail - Ubuntu Edgy + Postfix + Saslaught mrmagoo Server Operation 1 1st December 2006 15:56
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
TPS Ubuntu Dapper Postfix Problem assgoblin HOWTO-Related Questions 5 13th October 2006 15:57


All times are GMT +2. The time now is 12:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.