Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th August 2005, 18:54
Arien Arien is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default [error] an unkown filter was not added: PHP

Hi all!

I have installed ISPConfig following the Perfect Setup - Debian Sarge guide, but for now I'm having certain problems with my server.

One of them is this:

On /var/log/apache2/error.log I see that it's plenty of errors like

[Thu Aug 11 17:27:37 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 17:27:37 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 17:27:42 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 17:27:42 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 18:27:05 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 18:27:05 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 18:27:52 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 18:27:52 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 18:27:54 2005] [error] an unknown filter was not added: PHP
[Thu Aug 11 18:27:54 2005] [error] an unknown filter was not added: PHP


So I wonder if I make any mistake in the guide or just a common problem with apache2 and php4...

I have googled a bit and found something about:

"Regardless, you should replace those <Files *.php> with

AddType application/x-httpd-php .php

and similarly for .php3 etc."

But I couldn't see anything of this on php.conf ...

Can anybody help me?

Thanks and sorry for my english.
Reply With Quote
Sponsored Links
  #2  
Old 11th August 2005, 19:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Is the PHP module enabled in your Apache?

Try this:
Code:
cd /etc/apache2/mods-enabled
ln -s /etc/apache2/mods-available/php4.conf php4.conf
ln -s /etc/apache2/mods-available/php4.load php4.load
/etc/init.d/apache2 restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th August 2005, 19:14
Arien Arien is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found this:

lrwxrwxrwx 1 root root 37 Aug 5 17:35 php4.conf -> /etc/apache2/mods-available/php4.conf
lrwxrwxrwx 1 root root 37 Aug 5 17:35 php4.load -> /etc/apache2/mods-available/php4.load


So I suppose the answer is: yes.
Reply With Quote
  #4  
Old 15th August 2005, 08:03
jysse jysse is offline
Member
 
Join Date: Aug 2005
Location: Laihia, Finland
Posts: 31
Thanks: 0
Thanked 3 Times in 1 Post
Default Same problem here

I checked those links and they are ok.

lrwxrwxrwx 1 root root 37 Aug 8 20:31 php4.conf -> /etc/apache2/mods-available/php4.conf
lrwxrwxrwx 1 root root 37 Aug 8 20:31 php4.load -> /etc/apache2/mods-available/php4.load


Jysse

error.log:

[Mon Aug 15 08:58:15 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
[Mon Aug 15 08:58:17 2005] [notice] Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-15 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations
[Mon Aug 15 08:58:34 2005] [error] an unknown filter was not added: PHP
[Mon Aug 15 08:58:34 2005] [error] an unknown filter was not added: PHP
Reply With Quote
  #5  
Old 15th August 2005, 11:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you follow the tutorial http://www.howtoforge.com/perfect_setup_debian_sarge step by step? Did you make any changes?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 15th August 2005, 12:58
jysse jysse is offline
Member
 
Join Date: Aug 2005
Location: Laihia, Finland
Posts: 31
Thanks: 0
Thanked 3 Times in 1 Post
Default

Quote:
Originally Posted by falko
Did you follow the tutorial http://www.howtoforge.com/perfect_setup_debian_sarge step by step? Did you make any changes?
Yes sure, at least I tried to....One thing is that I can't remember what was my actions in error situation. Made a small mistake (typo) and after that a new install and everything went well. Maybe a fresh install would help ? If I have to I will do it, with some instructions how to do it ?

Jysse
Reply With Quote
  #7  
Old 15th August 2005, 13:06
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

Quote:
Originally Posted by jysse
Yes sure, at least I tried to....One thing is that I can't remember what was my actions in error situation. Made a small mistake (typo) and after that a new install and everything went well. Maybe a fresh install would help ? If I have to I will do it, with some instructions how to do it ?

Jysse
I dont think this "[Mon Aug 15 08:58:34 2005] [error] an unknown filter was not added: PHP" is an serious error, it is just a warning. If PHP is working in your sites created in ISPConfig, i recommend not to reinstall your server.
Reply With Quote
  #8  
Old 23rd October 2005, 21:24
jmroth jmroth is offline
ISPConfig Developer
 
Join Date: Sep 2005
Posts: 191
Thanks: 1
Thanked 6 Times in 6 Posts
Default

PHP Bug #22881 says: (it is not a bug!)

Quote:
Since 4.3.2RC the default Apache 2 sapi is the apache2handler and is no
longer filter based. Therefor you should use
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

and not

<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
So, the error message is nothing really bad and maybe ISPConfig should just look closer at the version of Apache and simply not include those lines in the config file... Using both AddType and Filters makes no sense anyway.
Reply With Quote
  #9  
Old 15th November 2005, 07:24
Bruce Bruce is offline
Junior Member
 
Join Date: Oct 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default Disable something in vhosts/Vhosts_ispconfig.conf

my mistake

Last edited by Bruce; 15th November 2005 at 07:51.
Reply With Quote
  #10  
Old 6th February 2006, 12:24
Ivan Ivan is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default [error] an unknown filter was not added: PHP

I have the same problem, tries:
ln -s /etc/httpd/mods-available/php5.conf php5.conf
ln -s /etc/httpd/mods-available/php5.load php5.load
/etc/init.d/httpd restart
But the problem I am not solved.

If he is not bug like solving it to install an application
My vhost is :
DocumentRoot /var/www/web33/web
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web33/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web33/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5

AddType application/x-httpd-php-source .phps
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
php_admin_value open_basedir /var/www/web33/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /var/www/web33/phptmp/
php_admin_value session.save_path /var/www/web33/phptmp/
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddOutputFilter INCLUDES .shtml
Alias /error/ "/var/www/web33/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web33/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web33/user/$1/web/$3
</VirtualHost>

Last edited by Ivan; 6th February 2006 at 12:27.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.