Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Programming/Scripts

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 21st April 2007, 18:44
wwwalker wwwalker is offline
Junior Member
 
Join Date: Apr 2007
Location: Orange NSW Australia
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via Yahoo to wwwalker Send a message via Skype™ to wwwalker
Default FreeBSD localisation

I found how to fix the Perl problem in FreeBSD:

http://www.freebsd.org/doc/en_US.ISO...alization.html

Set the environment variables LANG and MM_CHARSET in /etc/csh.login. (There are other places to do this but I used this - it worked!)

The list of locales are in:

/usr/share/locale

Make sure you spell the locale exactly. If you get the spelling wrong (mix up - and _) it will not work.
Reply With Quote
The Following User Says Thank You to wwwalker For This Useful Post:
falko (23rd April 2007)
Sponsored Links
  #12  
Old 7th August 2007, 22:40
Colin Dean Colin Dean is offline
Junior Member
 
Join Date: Aug 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by charles_elwood
It's also useful to check you have language-pack-?? installed, as that provides the actual locales. English speakers will most likely want language-pack-en.
This was the problem in my case. language-pack-en-base was not installed.
Code:
apt-get install language-pack-en-base
fixed it.
Reply With Quote
  #13  
Old 11th October 2007, 14:40
the_g_bomb the_g_bomb is offline
Junior Member
 
Join Date: Feb 2007
Location: Edinburgh
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

I found that a mixture of these cleared up this problem for me...

Code:
apt-get install locales localeconf
Select locales to be generated.

Code:
[*] en_GB ISO-8859-1[*] en_GB.ISO-8859-15 ISO-8859-15[*] en_GB.UTF-8 UTF-8
<-- Ok

Which locale should be the default in the system environment?<-- en_GB

Manage locale configuration files with debconf? <-- Yes
If you do not wish to use the default system locale… <-- Ok
Environment settings that should override the default locale: <-- Blank
Replace existing locale configuration files? <-- Yes
If you are not sure … always supported. <-- Ok
Default system locale: <-- en_GB.UTF-8 UTF-8
Obviously you will have to choose your own countries locales, but installing the locales and localeconf is the way the way to go.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PERL scripts in Mozilla Browser Deepthi Server Operation 3 20th December 2005 15:01
Installing Perl modules fernando Installation/Configuration 1 10th May 2005 21:16


All times are GMT +2. The time now is 15:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.