Prev Previous Post   Next Post Next
  #1  
Old 7th October 2007, 02:16
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 0 Times in 0 Posts
Default NIC Issues

Hi All, been awhile!

I finally broke down and bought my first laptop...

Came with MS Vista Home Premium... I installed suse10.2 x86 64 as a dual boot sys and no problems there.

suse however cannot seem to start the Realtec RTL8101 etho card (see's it and I can configure it but that is as far as I get) or even identify the Atheros AR 5007EG wireless card. Vista has some issues shutting down the LAN cards when shutdown and so I disabled "wake on LAN" function and still no progress. I downloaded the drivers for the RTL8101 from Realtec and can't seem to install them the following is a summary of the install attempt.

Can anyone tell me what I am doing wrong, or missing?

Code:
linux-mobile:/tmp # tar vjxf r8168-8.003.00.tar.bz2
r8168-8.003.00/
r8168-8.003.00/.svn/
r8168-8.003.00/.svn/entries
r8168-8.003.00/.svn/format
r8168-8.003.00/.svn/props/
r8168-8.003.00/.svn/prop-base/
r8168-8.003.00/.svn/tmp/
r8168-8.003.00/.svn/tmp/props/
r8168-8.003.00/.svn/tmp/prop-base/
r8168-8.003.00/.svn/tmp/text-base/
r8168-8.003.00/.svn/all-wcprops
r8168-8.003.00/.svn/text-base/
r8168-8.003.00/.svn/text-base/Makefile.svn-base
r8168-8.003.00/.svn/text-base/release_note.txt.svn-base
r8168-8.003.00/.svn/text-base/README.svn-base
r8168-8.003.00/readme
r8168-8.003.00/src/
r8168-8.003.00/src/.svn/
r8168-8.003.00/src/.svn/entries
r8168-8.003.00/src/.svn/format
r8168-8.003.00/src/.svn/props/
r8168-8.003.00/src/.svn/prop-base/
r8168-8.003.00/src/.svn/tmp/
r8168-8.003.00/src/.svn/tmp/props/
r8168-8.003.00/src/.svn/tmp/prop-base/
r8168-8.003.00/src/.svn/tmp/text-base/
r8168-8.003.00/src/.svn/all-wcprops
r8168-8.003.00/src/.svn/text-base/
r8168-8.003.00/src/.svn/text-base/r8168_n.c.svn-base
r8168-8.003.00/src/.svn/text-base/Makefile.svn-base
r8168-8.003.00/src/.svn/text-base/r8168.h.svn-base
r8168-8.003.00/src/.svn/text-base/rtl_ioctl.h.svn-base
r8168-8.003.00/src/.svn/text-base/rtl_ioctl.c.svn-base
r8168-8.003.00/src/rtl_ioctl.c
r8168-8.003.00/src/r8168_n.c
r8168-8.003.00/src/r8168.h
r8168-8.003.00/src/Makefile
r8168-8.003.00/src/rtl_ioctl.h
r8168-8.003.00/Makefile
r8168-8.003.00/release_note.txt

linux-mobile:/tmp # cd /tmp/r8168-8.003.00

linux-mobile:/tmp/r8168-8.003.00 # make clean modules
make -C src/ clean
make[1]: Entering directory `/tmp/r8168-8.003.00/src'
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers
make[1]: Leaving directory `/tmp/r8168-8.003.00/src'
make -C src/ modules
make[1]: Entering directory `/tmp/r8168-8.003.00/src'
make -C /lib/modules/2.6.18.2-34-default/build SUBDIRS=/tmp/r8168-8.003.00/src modules
make[2]: Entering directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
make[2]: *** No rule to make target `modules'.  Stop.
make[2]: Leaving directory `/usr/src/linux-2.6.18.2-34-obj/x86_64/default'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/tmp/r8168-8.003.00/src'
make: *** [modules] Error 2

linux-mobile:/tmp/r8168-8.003.00 # make install
make -C src/ install
make[1]: Entering directory `/tmp/r8168-8.003.00/src'
install -m 644 -c r8168.ko /lib/modules/2.6.18.2-34-default/kernel/drivers/net/
install: cannot stat `r8168.ko': No such file or directory
make[1]: *** [install] Error 1
make[1]: Leaving directory `/tmp/r8168-8.003.00/src'
make: *** [install] Error 2

linux-mobile:/tmp/r8168-8.003.00 # depmod -a

linux-mobile:/tmp/r8168-8.003.00 # insmod ./src/r8168.ko
insmod: can't read './src/r8168.ko': No such file or directory

linux-mobile:/tmp/r8168-8.003.00 # lsmod|grep r8168

linux-mobile:/tmp/r8168-8.003.00 # ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1B:38:13:AE:19
          inet addr:192.168.2.6  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:50 Base address:0x2000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:80 errors:0 dropped:0 overruns:0 frame:0
          TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5216 (5.0 Kb)  TX bytes:5216 (5.0 Kb)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to start/bring up a nic at boot that has no IP systimax Server Operation 3 12th May 2007 18:19
Couple issues with ispconfig 2.2.12 after Fiesty upgrade pyropoptrt Installation/Configuration 15 1st May 2007 20:37
Fail to detect NIC satimis Technical 2 24th March 2007 14:38
rdiff-backup on a specific nic card? jake.conk HOWTO-Related Questions 3 20th January 2007 18:19
ISPConfig + Turck MMCache + Hardened-PHP - Any Issues? BobbyQ General 8 3rd May 2006 22:52


All times are GMT +2. The time now is 10:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.