Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 5th October 2007, 18:29
gauthier gauthier is offline
Member
 
Join Date: Oct 2007
Posts: 58
Thanks: 5
Thanked 3 Times in 2 Posts
Default Remoting Framework / xml instalation issue

Hi, please forgive my unknowledge.

I installed ISPconfig v2.2.17 on centos4.4 following "perfect setup" instructions. I tried to make my best, ISPconfig is now running fine (this is a great control panel), thanks to members and administradors of this forum.

I have now a problem with Remoting Framework.
I installed the remoting extension fine, and created remote user.
Then I tried the test.php example, it do not work (blank page).

Went to php.ini: and "display_errors On".
I have some irrevelant "notice", but no "warnings".
I edit soap.lib.php and add the following "echo":

$return = $this->send($soapmsg,$soapAction,$this->timeout);
echo 'return='.gettype($return).'<br>';

It displays:"return=NULL", ok there is something wrong related to the send function.

I add the following "echo" in the "send" function:

$response = $http->sendHTTPS($msg,$timeout);
echo $response.'<br>';

It displays:

Fatal error: Call to undefined function xml_parser_create() in /home/admispconfig/ispconfig/lib/classes/ispconfig_soap.obj.php on line 3256

Ok. I have got it, but how shall I fix it?

I checked xml installation.

phpinfo() displays:
XML Support active
XML Namespace Support active
EXPAT Version expat_1.95.7

Fine no?

Tried to download and install:
http://www.ispconfig.org/downloads/I....1.2xml.tar.gz
->This link no longer runs, I do not know if it is still necesary.

Tried:
cpan>install XML::Parser
->displays "XML::Parser is up to date"

I suppected something wrong with my "perfect" centos4.4 setup.

I redo some installation steps and I find this:
In instruction "yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel", php-xmlrpc package is found and installed but php-xml package is not found.

yum install php-xml displays "Cannot find a package matching xml-php"

Could you please tell me if you have any idea of what I am doing wrong ? Is this an xml installation issue ? May I change my php.ini to add any extension ?

Thanks a lot.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting remoting framework working catdude Installation/Configuration 4 16th August 2007 15:34
Adding a Web Remoting Framework bigger_travis General 1 13th July 2007 20:26
remoting framework problem with 2.2.14 mumbly Installation/Configuration 27 11th July 2007 20:17
Remoting framework still show black block under tools mxc Installation/Configuration 2 26th February 2007 07:13
Remoting Framework mlz General 9 18th January 2007 22:52


All times are GMT +2. The time now is 14:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.