Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th September 2007, 22:38
adamlike adamlike is offline
Junior Member
 
Join Date: Sep 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix problem(loops back to myself)

I'm follow this http://www.howtoforge.com/virtual_us...debian_etch_p2
but i can't receive any email
only can send out the email ~

Sep 30 04:26:23 monday postfix/smtp[9204]: 18CEB3546CC: to=<info@xxxxx.com>, relay=none, delay=0.07, delays=0.06/0/0/0, dsn=5.4.6, status=bounced (mail for xxxxx.com loops back to myself)

how to fix the problem ? loops back to myself ?
Reply With Quote
Sponsored Links
  #2  
Old 30th September 2007, 20:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Add xxxxx.com to the mydestination line in /etc/postfix/main.cf and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st October 2007, 13:57
adamlike adamlike is offline
Junior Member
 
Join Date: Sep 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

But i use the mysql to store the virtual user .
how can i do ?

quote some main.cf

myhostname = xxxx.xxxx.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = $myhostname, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
Reply With Quote
  #4  
Old 2nd October 2007, 15:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Do you use xxxxx.com for virtual users? If not, change the mydestination line to
Code:
mydestination = $myhostname, localhost, localhost.localdomain, xxxxx.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th October 2007, 20:16
adamlike adamlike is offline
Junior Member
 
Join Date: Sep 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry ...i have try ...but still have problem !
Reply With Quote
  #6  
Old 1st September 2011, 14:56
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
Default

Same here

This is my log
Code:
Sep  1 14:47:53 filtro postfix/smtpd[4203]: connect from mail-ww0-f45.google.com[74.125.82.45]
Sep  1 14:47:53 filtro postfix/policy-spf[4210]: : SPF pass (Mechanism 'ip4:74.125.0.0/16' matched): Envelope-from: alleksesp@gmail.com
Sep  1 14:47:53 filtro postfix/policy-spf[4210]: handler sender_policy_framework: is decisive.
Sep  1 14:47:53 filtro postfix/policy-spf[4210]: : Policy action=PREPEND Received-SPF: pass (gmail.com ... _spf.google.com: 74.125.82.45 is authorized to use 'sender@gmail.com' in 'mfrom' identity (mechanism 'ip4:74.125.0.0/16' matched)) receiver=filter.gaga.com; identity=mailfrom; envelope-from="sender@gmail.com"; helo=mail-ww0-f45.google.com; client-ip=74.125.82.45
Sep  1 14:47:54 filtro postfix/smtpd[4203]: 00A98181738: client=mail-ww0-f45.google.com[74.125.82.45]
Sep  1 14:47:54 filtro postfix/cleanup[4211]: 00A98181738: hold: header Received: from mail-ww0-f45.google.com (mail-ww0-f45.google.com [74.125.82.45])??by filter.gaga.com (Postfix) with ESMTPS id 00A98181738??for <admin@destination.com>; Thu,  1 Sep 2011 14:47:53 + from mail-ww0-f45.google.com[74.125.82.45]; from=<sender@gmail.com> to=<admin@destination.com> proto=ESMTP helo=<mail-ww0-f45.google.com>
Sep  1 14:47:54 filtro postfix/cleanup[4211]: 00A98181738: message-id=<CALXpz5iQU89h3WuGMBd6UaY3ALUia8S-J9zNHxDjzwzRs0HX4g@mail.gmail.com>
Sep  1 14:47:57 filtro MailScanner[1232]: New Batch: Scanning 1 messages, 2574 bytes
Sep  1 14:47:57 filtro MailScanner[1232]: Virus and Content Scanning: Starting
Sep  1 14:48:01 filtro CRON[4219]: (root) CMD (baruwa-admin queuestats 2>/dev/null)
Sep  1 14:48:03 filtro postfix/pickup[3633]: 2FBE518174C: uid=0 from=<root>
Sep  1 14:48:03 filtro postfix/cleanup[4211]: 2FBE518174C: message-id=<20110901124803.2FBE518174C@filter.gaga.com>
Sep  1 14:48:03 filtro postfix/qmgr[3634]: 2FBE518174C: from=<root@filter.gaga.com>, size=849, nrcpt=1 (queue active)
Sep  1 14:48:03 filtro postfix/error[4234]: 2FBE518174C: to=<root@filter.gaga.com>, orig_to=<root>, relay=none, delay=0.08, delays=0.02/0.03/0/0.03, dsn=5.0.0, status=bounced (No local mail delivery)
Sep  1 14:48:03 filtro postfix/cleanup[4211]: 41A8D18174D: message-id=<20110901124803.41A8D18174D@filter.gaga.com>
Sep  1 14:48:03 filtro postfix/qmgr[3634]: 41A8D18174D: from=<>, size=2741, nrcpt=1 (queue active)
Sep  1 14:48:03 filtro postfix/bounce[4235]: 2FBE518174C: sender non-delivery notification: 41A8D18174D
Sep  1 14:48:03 filtro postfix/qmgr[3634]: 2FBE518174C: removed
Sep  1 14:48:03 filtro postfix/error[4234]: 41A8D18174D: to=<root@filter.gaga.com>, relay=none, delay=0.02, delays=0.01/0/0/0.01, dsn=5.0.0, status=bounced (No local mail delivery)
Sep  1 14:48:03 filtro postfix/qmgr[3634]: 41A8D18174D: removed
Sep  1 14:48:08 filtro MailScanner[1232]: Expired 4 records from the SpamAssassin cache
Sep  1 14:48:08 filtro MailScanner[1232]: Baruwa whitelist refresh time reached
Sep  1 14:48:08 filtro MailScanner[1232]: Starting Baruwa whitelists
Sep  1 14:48:08 filtro MailScanner[1232]: Read 1 whitelist items
Sep  1 14:48:08 filtro MailScanner[1232]: Ip blocks whitelisted:
Sep  1 14:48:08 filtro MailScanner[1232]: Baruwa blacklist refresh time reached
Sep  1 14:48:08 filtro MailScanner[1232]: Starting Baruwa blacklists
Sep  1 14:48:08 filtro MailScanner[1232]: Read 0 blacklist items
Sep  1 14:48:08 filtro MailScanner[1232]: Ip blocks blacklisted:
Sep  1 14:48:13 filtro MailScanner[1232]: Requeue: 00A98181738.A898F to 9CE4418174B
Sep  1 14:48:13 filtro postfix/qmgr[3634]: 9CE4418174B: from=<sender@gmail.com>, size=1861, nrcpt=1 (queue active)
Sep  1 14:48:13 filtro MailScanner[1232]: Uninfected: Delivered 1 messages
Sep  1 14:48:13 filtro MailScanner[1232]: Deleted 1 messages from processing-database
Sep  1 14:48:13 filtro MailScanner[1232]: Logging message 00A98181738.A898F to Baruwa SQL
Sep  1 14:48:13 filtro postfix/smtp[4241]: 9CE4418174B: to=<admin@destination.com>, relay=none, delay=21, delays=21/0.04/0/0, dsn=5.4.6, status=bounced (mail for destination.com loops back to myself)
Sep  1 14:48:13 filtro postfix/cleanup[4211]: EC281181739: message-id=<20110901124813.EC281181739@filter.gaga.com>
Sep  1 14:48:13 filtro postfix/qmgr[3634]: EC281181739: from=<>, size=3912, nrcpt=1 (queue active)
Sep  1 14:48:13 filtro postfix/bounce[4236]: 9CE4418174B: sender non-delivery notification: EC281181739
Sep  1 14:48:13 filtro postfix/qmgr[3634]: 9CE4418174B: removed
Sep  1 14:48:15 filtro postfix/smtp[4242]: EC281181739: to=<sender@gmail.com>, relay=gmail-smtp-in.l.google.com[209.85.227.27]:25, delay=1.8, delays=0/0.02/0.16/1.6, dsn=2.0.0, status=sent (250 2.0.0 OK 1314881290 13si28370wbw.57)
Sep  1 14:48:15 filtro postfix/qmgr[3634]: EC281181739: removed
and my main.cf
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = filter.gaga.com
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = filter.gaga.com
mydomain = gaga.com

myorigin = filter.gaga.com
mydestination = localhost.filter.gaga.com, localhost.localdomain, localhost, filter.gaga.com
#mynetworks = 127.0.0.0/8, 192.168.0.0/24
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases

relayhost =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
message_size_limit = 10485760
local_transport = error:No local mail delivery
local_recipient_maps =
relay_domains = mysql:/etc/postfix/mysql-relay_domains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-relay_recipients.cf
transport_maps = mysql:/etc/postfix/mysql-transports.cf
#virtual_alias_domains = area-innova.com, filtro.area-innova.com
#virtual_alias_maps = hash:/etc/postfix/virtual
disable_vrfy_command = yes
strict_rfc821_envelopes = no
smtpd_delay_reject = yes
smtpd_recipient_limit = 100
smtpd_helo_required = yes
smtpd_client_restrictions = permit_sasl_authenticated, permit_mynetworks, permit
smtpd_helo_restrictions = permit_sasl_authenticated, permit_mynetworks, permit
smtpd_sender_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_sender, reject_unknown_sender_domain, permit
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unknown_recipient_domain, reject_unauth_destination, look_ahead, whitelist_policy, grey_policy, rbl_policy, spf_policy, permit
smtpd_data_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_pipelining
smtpd_restriction_classes = spf_policy, rbl_policy, grey_policy, whitelist_policy, verify_recipient, look_ahead
spf_policy = check_policy_service unix:private/policy
rbl_policy = reject_rbl_client zen.spamhaus.org, reject_rbl_client bl.spamcop.net
grey_policy = check_policy_service unix:private/greyfix
whitelist_policy = check_client_access mysql:/etc/postfix/mysql-global_whitelist.cf, check_sender_access mysql:/etc/postfix/mysql-global_whitelist.cf
header_checks = regexp:/etc/postfix/header_checks

verify_recipient = reject_unknown_recipient_domain, reject_unverified_recipient
look_ahead = check_recipient_access hash:/etc/postfix/access
unverified_recipient_reject_code = 550
address_verify_map = btree:/var/lib/postfix/verify
What could be wrong?
Reply With Quote
  #7  
Old 2nd September 2011, 14:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Sep 1 14:48:13 filtro postfix/smtp[4241]: 9CE4418174B: to=<admin@destination.com>, relay=none, delay=21, delays=21/0.04/0/0, dsn=5.4.6, status=bounced (mail for destination.com loops back to myself)
Add destination.com to the mydestination line in /etc/postfix/main.cf and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 5th September 2011, 10:50
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
Default

With mydestination = destination.com I get Recipient address rejected: No local mail delivery

Code:
Sep  5 10:45:32 filtro postfix/smtpd[23496]: NOQUEUE: reject: RCPT from mail-wy0-f177.google.com[74.125.82.177]: 550 5.1.1 <alex@destination.com>: Recipient address rejected: No local mail delivery; from=<alex@gmail.com> to=<alex@destination.com> proto=ESMTP helo=<mail-wy0-f177.google.com>

Last edited by alleks; 5th September 2011 at 12:22.
Reply With Quote
  #9  
Old 5th September 2011, 15:05
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
 
Default

My problem was based on following the tutorial The Perfect SpamSnake and I found the solution. I restored my main.cf and rad again this paragraph in the spamsnake tutorial:

Quote:
Setup Instructions for Baruwa

Log into Baruwa as admin --> Settings --> Accounts --> Create Account

Once you've created the user account, you'll get two new tabs on that page, Profile Settings and Associated Addresses.

Fill out Profile Settings choosing Domain Admin and set a low score of 6 and a high score of 9 and check scan email.

Click the + sign under Associated Addresses and enter a domains for which the user is the admin of eg. domain.com. domain.com will show up under Associated Addresses.

Click on domain.com and you'll be taken into Domain Information, where you'll be able to setup SMTP delivery information. Go ahead and add the receiving smtp server, or the ip of the receiving smtp server. Select enable and if you use a non-standard port, set it, otherwise use 25. Once you've done that, you can click on the test button next to the pencil, to see if your receiving server will accept the connection.

Now, you can log out as admin, and log in as the user you just setup and mails should start flowing.

The relay_recipients, relay_domains and transports settings in /etc/postfix/main.cf will use the entries you've provided in Baruwa. Therefore, no hash file is required.
The associated queries in the mysql cf files will pull the result in the proper format and feed it to postfix for use.

However, if you'd like to use a hash for any of your config files, use the following as an example of how to setup /etc/postfix/main.cf:
Reply With Quote
The Following User Says Thank You to alleks For This Useful Post:
falko (6th September 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with Postfix using "Virtual Users And Domains With Postfix, Courier And MySQL" Kyse HOWTO-Related Questions 15 6th January 2007 15:35
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Postfix : mail loops back vincentthe Installation/Configuration 1 14th November 2006 10:38
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Postfix Loops Back error and weird email headers reimagine General 4 28th July 2006 09:04


All times are GMT +2. The time now is 20:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.