Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 19th July 2005, 13:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Did you try and reboot your server? Maybe your problems are gone then.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 19th July 2005, 20:20
davidg davidg is offline
Junior Member
 
Join Date: Jul 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I have rebooted the server 3 times.

Do you think there is anything in SuSEconfig that could cause problems?

Should I uninstall and reinstall ISPConfig again, if so should I do anything after I run the uninstall routine.
Reply With Quote
  #13  
Old 19th July 2005, 22:10
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Quote:
Originally Posted by davidg
Yes I have rebooted the server 3 times.

Do you think there is anything in SuSEconfig that could cause problems?
yes, maybe. Are you shure vsftpd is not installed
beside proFTPD?

Quote:
Originally Posted by davidg
Should I uninstall and reinstall ISPConfig again, if so should I do anything after I run the uninstall routine.
No, that would not help. This is not a problem of the ISPConfig
setup. The problem is that there are other processes
running that are bound to the FTP ports.

You have to identify the programs that are bound to the ports
and stop them, before you can start the proftpd daemon.

If you want me or Falko login to your server and have a look at your
setup, please contact me via email: t.brehm [at] ispconfig [dot] org
Reply With Quote
  #14  
Old 20th July 2005, 03:52
davidg davidg is offline
Junior Member
 
Join Date: Jul 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Proftpd worked before I re-installed ISPConfig.

All I did was uninstall ISPConfig then reboot the server, then install ISPConfig with the same setup I had before. I chose the complete uninstall option. I used expert mode to use suexec for cgi as per the documentation.

ISPConfig worked before with proftpd then I reinstalled and everything works except proftpd.

Thanks for all your help.
Reply With Quote
  #15  
Old 20th July 2005, 12:16
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default Problem solved

The ProFTPD on SuSe needed the following additional directive
in the proftpd.conf cofiguration file:

SocketBindTight on

to start correctly with an virtual IP configuration.
We added this to the Tutorial on Howtoforge too.

Explanation from the proFTPD vHosting Howto:
http://www.castaglia.org/proftpd/doc...WTO-Vhost.html

....
There is one last configuration directive about which an administrator should know: SocketBindTight. By default, the proftpd daemon will listen on all addresses, port 21, for the connection requests of remote clients. Sometimes, the administrator may wish to have the proftpd daemon listen only on the IP addresses for which it has been configured, and not every address. To accomplish this, simply use the SocketBindTight configuration directive:

SocketBindTight on

This configures the daemon to "bind tightly" only to those IP addresses to which it has been configured to listen, rather than every address. By default, the proftpd daemon will listen to every address on the host machine.
....

Intersting thing: On e.g Debian or Mandrake this directive is not nescessary,
maybe its related to the newer ProFTPD version.


Till

Last edited by till; 20th July 2005 at 12:18.
Reply With Quote
  #16  
Old 11th August 2005, 03:56
jcartland jcartland is offline
Junior Member
 
Join Date: Aug 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default proftpd offline, 'already bound'

I had the same problem on SuSE 9.3, spent quite a while chasing it --
Quote:
Originally Posted by davidg
....
I uninstalled and reinstalled and everything is working except the proftpd.

Message log states:
unable to create ipbind 'xxx.xxx.x.51:21 already bound to 'ProFTPD Default Installation'
...
ISPConfig shows offline and will not restart.
What worked once was to kill both proftpd AND ispconfig, edit the proftpd.conf, and THEN run /etc/init.d/ispconfig start. Thought I had it solved, then had the same problem again. It's working now, problem seems to be that I'd installed proftpd to start at boot, then ispconfig was trying to start it again.

PS - Thanks for this project. Before I found it, I spent way too much time trying to configure a control panel project, written in perl, which has "gone professional". This is better code and better attitude.

Last edited by jcartland; 11th August 2005 at 17:25.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.