Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th December 2005, 13:09
jeanjacquesjeanjacques jeanjacquesjeanjacques is offline
Member
 
Join Date: Nov 2005
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Red face Mysql assignation to a new website

Hello,
When i try to create a website using the admin account i have this error message:
"You cannot assign shell access to this website.
You cannot assign MySQL databases to this website"
I tried to look for informations inside the forum but i've found nothing.
Is there someone who knos how could i fix this ?

Best regards,

Jean-Jacques
Reply With Quote
Sponsored Links
  #2  
Old 8th December 2005, 16:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Are you sure you tried this as admin and not as a reseller? Please double-check.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 30th January 2006, 15:31
st2xo st2xo is offline
Member
 
Join Date: Jan 2006
Location: Wiesloch [DE]
Posts: 47
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Hi - I have the same problem ...

Just installed the default ("perfect setup") ispconfig installation with no problems, all looks fine. I did not have changed any settings, except to add a reseller and a client account (reseller added as admin, client added as reseller)
The only difference from the default setup I made was the mysql databasename/prefix: I used ISPCONFIG (default was "ispconfigdb" I think)

the result after adding a web in "site management" is
"You cannot assign MySQL databases to this website."
"Sie können diesem Web keine MySQL-Datenbanken zuordnen." (same in german)

This occurs as admin and as reseller and with a web-template or with "individual settings", or with "-1" allowed databases or with a number, eg. 10
So its not possible to create a new web with databases (one or more)

I switched from admin to reseller and backward by logging out and closing the browser. So all session-data should have been deleted.

Does anybody have a hint for me? Many thanks in advance!

And - last but not least - with my first posting I want to thank for providing ISPConfig! Not only ISPcofig for itself must be great (I could not try it until now :-), even the documentation, installation at last this support forum and the community is outstanding of many projects I know!
__________________
regards,
Stefan.
Reply With Quote
  #4  
Old 30th January 2006, 17:38
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
Default

The error might occur if you have not set and saved the limits of the reseller.

Please login as admin, open the reseller settings of the reseller you are talking about, go to the limits tab, check if all limits are ok and the save the reseller again.

Then try again to add the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 30th January 2006, 17:53
st2xo st2xo is offline
Member
 
Join Date: Jan 2006
Location: Wiesloch [DE]
Posts: 47
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Yes, that´s it!

The "number of databases" setting was correct with "-1" or a number.
But the checkbox "mysql" wasnt checked and I havent seen it

I could sware it was checked at first time - eyes and brain are getting older. Thank you!
__________________
regards,
Stefan.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Client Website MySQL Database Names Lister Installation/Configuration 4 12th January 2008 17:21
Failed at MySQL lhatle Installation/Configuration 4 29th November 2005 01:26
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41
Mysql ejs Installation/Configuration 5 12th August 2005 07:01


All times are GMT +2. The time now is 12:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.