Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th August 2007, 23:43
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default Added e-mail accounts not getting flushed to /etc/passwd

I've added a handful of e-mail users to a few of my customers. I see them in the database, and I've gone in and entered passwords for all of them. When I do "select web_host, web_domain, status from isp_isp_web" I see all of those customers, with a status of 'u'.

When I do "select user_username, status from isp_isp_user where user_username like 'cust_domain.com_%';" I see all of the recently entered e-mail address with a status of 'n'.

The /etc/passwd and /etc/shadow files are never getting updated with entries for these users. Even if I go into an existing mail account in one of these domains and change a mail quota, the disk files are never getting updated.

What am I missing here? Should these changes I've made through the ISPConfig web interface force a disk update to occur?
Reply With Quote
Sponsored Links
  #2  
Old 31st August 2007, 02:07
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default Never mind...

I added a couple of debugging lines to write progress notes to a log file, and I left off the closing quotes.
Reply With Quote
  #3  
Old 31st August 2007, 09:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
 
Default

I guess the daemon process died. Please run:

/etc/init.d/ispconfig_server restart

When you change now something in the interface, all changes shall be written to disk.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18
Postfix reject connections gabrix Server Operation 27 25th January 2007 09:37
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 13:16
php script injections Grizzly General 21 18th July 2006 09:55
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47


All times are GMT +2. The time now is 20:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.