Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th August 2007, 21:38
hendry hendry is offline
Junior Member
 
Join Date: Dec 2005
Location: Apeldoorn, The Netherlands
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to hendry Send a message via MSN to hendry Send a message via Yahoo to hendry
Default Apache2 constantly crashing

HELP! My Apache2 is constantly crashing. When logging in to the adminpart of ISPConfig I see the service is unavailable. I can restart it from the shell and then it runs again for a couple of minutes. What can it be? Running on the latest stable version (just updated it in the hope it would fix something) on a Suse 10.1 VPS server at Strato. Is there a place where I can find the reason of crashing? Cannot find it in the apache errorlog
Reply With Quote
Sponsored Links
  #2  
Old 28th August 2007, 21:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,405
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Please have a look at the apache error log under /var/log/... and in the error logs of your websites. Also have a look in the messages and syslog.

As your server is a VPS server, it might be that you just reached the limits. Have a look at the beancounters (if your vps is a openvz or virtuozzo system) with:

cat /proc/user_beancounters

Do you have any failcnt?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th August 2007, 21:52
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,259
Thanks: 215
Thanked 648 Times in 294 Posts
Default

On Debian the log files for Apache are within:

/var/log/apache2/error.log
/var/log/apache2/access.log

I guess for Suse it is something like that too.

You can follow what's happening with the commands:

tail -f /var/log/apache2/error.log
tail -f /var/log/apache2/access.log
__________________
Hans

MrHostman | Master in managed hosting
Reply With Quote
  #4  
Old 28th August 2007, 22:16
hendry hendry is offline
Junior Member
 
Join Date: Dec 2005
Location: Apeldoorn, The Netherlands
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to hendry Send a message via MSN to hendry Send a message via Yahoo to hendry
Default

Thank you: this is the ouput of the counters:


Version: 2.5
uid resource held maxheld barrier limit failcnt
1318424: kmemsize 4700995 4992722 8512433 9823665 468
lockedpages 0 0 3800 4096 0
privvmpages 69939 72330 138256 202568 64
shmpages 8971 9611 131072 131072 0
dummy 0 0 0 0 0
numproc 63 67 232 232 0
physpages 22671 24157 0 2147483647 0
vmguarpages 0 0 66400 2147483647 0
oomguarpages 22671 24157 66400 2147483647 0
numtcpsock 15 23 500 500 0
numflock 12 18 200 232 0
numpty 1 2 64 64 0
numsiginfo 0 3 512 512 0
tcpsndbuf 127452 182976 4683256 6102456 0
tcprcvbuf 182596 249020 4683256 6102456 0
othersockbuf 176644 190776 1503232 4063232 0
dgramrcvbuf 0 0 240000 262144 0
numothersock 118 126 382 382 0
dcachesize 0 0 2194304 2317184 0
numfile 2462 2746 5432 5432 5305
dummy 0 0 0 0 0
dummy 0 0 0 0 0
dummy 0 0 0 0 0
numiptent 14 14 128 128 0

kmemsize has a lot of errors. Does this mean the server has to less memory?
Reply With Quote
  #5  
Old 29th August 2007, 08:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,405
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

You might want to try to configure your apache to start less instances and set the max number of instances to a lowe limit in apache configuration.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 29th August 2007, 09:15
hendry hendry is offline
Junior Member
 
Join Date: Dec 2005
Location: Apeldoorn, The Netherlands
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to hendry Send a message via MSN to hendry Send a message via Yahoo to hendry
Default

Quote:
Originally Posted by till
You might want to try to configure your apache to start less instances and set the max number of instances to a lowe limit in apache configuration.
Ok, thank you, but can you help me with this? I don't know where to find these settings
Reply With Quote
  #7  
Old 29th August 2007, 18:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

Take a look here: http://www.howtoforge.com/configurin...um_performance
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to start apache2 on Heart beat amohammad Installation/Configuration 10 10th November 2009 08:19
SSI with Apache2 on Debian jchaven Server Operation 7 25th August 2008 17:06
Apache2 without APXS ctroyp Installation/Configuration 8 29th January 2007 03:05
Web server offline after php4 and apache2 upgrade dfriis Installation/Configuration 11 7th December 2006 16:14
PHP on Apache2 no longer works after ISPconfig azorman Installation/Configuration 6 23rd July 2006 22:06


All times are GMT +2. The time now is 07:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.