Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th August 2007, 22:20
spazio spazio is offline
Member
 
Join Date: Apr 2007
Posts: 38
Thanks: 1
Thanked 2 Times in 2 Posts
Default ispconfig change remote mailserver by itself

The version installed is 2.3.1. on a debian box. I know i just realised that it's the dev version. First thing first, is there a way to upgrate to the production version 2.2.15 or is it best to stick to 2.3.2-dev?

The serveur changed all domain from local mailserver to remote mailserver by itself last night! The change was in the options of the site and in the domain alias as well. The result being the removal of all informations in the 2 following files.
/etc/postfix/virtualusertable and
/etc/postfix/local-host-names

Naturally, the effect of those changes being the reject of all incomming mail

Any idea of what happened? And is there a way to prevent this in the futur?

Thanks in advance for anyhelp...
Reply With Quote
Sponsored Links
  #2  
Old 16th August 2007, 22:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Quote:
The version installed is 2.3.1. on a debian box. I know i just realised that it's the dev version. First thing first, is there a way to upgrate to the production version 2.2.15 or is it best to stick to 2.3.2-dev?
You can not downgrade as the the database structures are not downwards compatible.

Quote:
The serveur changed all domain from local mailserver to remote mailserver by itself last night! The change was in the options of the site and in the domain alias as well. The result being the removal of all informations in the 2 following files.
/etc/postfix/virtualusertable and
/etc/postfix/local-host-names
This happens if the domain has no valid MX record in DNS pointing to your server. To fix this, create a MX record that point to your server.

Or you disable this security function in ISPConfig under management > server > settings on the mail tab.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th August 2007, 23:01
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
 
Default

This is do to a check of the MX int the dev version. If the MX of the domain is not set to the server, it automatically sets the domain to an external mail server. You can deactivate this behavior, but I don't recall the exact menu, and I don't have a dev server here actually, so you will have to search

[Edit]
Or just do what Till told you
[/Edit]
Reply With Quote
The Following User Says Thank You to jnsc For This Useful Post:
till (16th August 2007)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig after installation cannot reach www.xyz.de:81 Figth4Linux Installation/Configuration 23 6th March 2008 22:38
ISPConfig Roadmap till Developers' Forum 26 10th June 2007 22:38
How to change ISPconfig admin interface timout Clogboy General 2 23rd January 2007 13:03
How to host own DNS Service in remote ISPConfig server? zenny Installation/Configuration 3 4th January 2007 15:15
ISPConfig 2.3.1-dev released till General 0 8th May 2006 22:18


All times are GMT +2. The time now is 02:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.