Prev Previous Post   Next Post Next
  #1  
Old 16th August 2007, 18:06
Sidi Sidi is offline
Junior Member
 
Join Date: Aug 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig kills system user?

Hi,

I thing I have found a litte bug in ISPConfig 2.3.12 (yes, I know it isn't
the latest, but I havn't seen this in the changelog):

If a reseller add a new (email-) user, ISPConfig doesn't seem to check if
this name already exists as an systemuser in /etc/passwd.

I had for example a user "martin" with UID 1000, ISPConfig uses UID's > 10000. A reseller had add an email-user "martin" which was added with UID 10318 and my old "martin" was deleted in the /etc/passwd.

Haven't checked yet if you also can delete such users as "uucp", "www-data" or even "root" this way.

regards,
martin
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
admispconfig invalid user johann Installation/Configuration 4 15th January 2009 19:51
The PHP binary coming with ISPConfig does not work properly on your system! DreamState Installation/Configuration 15 22nd October 2006 07:31
Can't access ISPConfig on 2 month old system. digerata Installation/Configuration 3 21st August 2006 17:30
Restarted Perfect System and Lost ISPConfig! iratik Installation/Configuration 2 16th August 2006 10:05


All times are GMT +2. The time now is 22:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.