Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 30th July 2007, 17:19
koi koi is offline
Member
 
Join Date: Jan 2007
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default debian, lvm, raid, grub, custom kernel

Hi I have a problem.
I have a debian etch stable.
I made this setup:
3 hd.
3 x 1 gb for /boot raid 1 (out of lvm)
3 x 15 gb for / raid 5 (lvm)
3 x 20 gb for /home raid 5 (lvm)
3 x 256 mb for swap raid 5 (lvm)

I made all during the installation process. I have used lvm on raid 5 partitions.
I have never used lvm before, "only" raid.

The problem is that i have always recompiled kernel by vanilla sources, and i never used initrd cause the "important" things i am usual to put "built in " in the kernel configuration.

This time, with lvm, it doesn't work:
so: Do I have left something out of the kernel? (is dm-mod the part about lvm, right?) ?
Do I need initrd the same?

The error I get during boot is (after raid is corretly started):
VFS: cannot open root device "mapper/name-of-the-volume" or unknown-block (0,0)
Please append a correct "root=" boot option
md0 (driver?)*
kernel panic not syncing vfs: unable to mount root fs on unknown-block (0,0)

* md0 is the raid 5 metadevice

Thans in advance.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
Xen 3.0.2 /3.0.3 | No Swap in DomU Merc HOWTO-Related Questions 10 27th March 2007 11:40
WG311v2 almost working with Edgy (w/o ndiswrapper) need help with the rest caudata Server Operation 11 13th November 2006 20:02
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 12:59


All times are GMT +2. The time now is 13:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.