Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th June 2007, 02:33
astra2000 astra2000 is offline
Junior Member
 
Join Date: Jun 2007
Posts: 20
Thanks: 4
Thanked 1 Time in 1 Post
Default Please help me whit bind9

Hello party peopel, i'm tryng config the bind9 (first time)
and i think is all ok but i can't ping the adress...

check this out:


on /etc/bind/zones/master

i have 2 files:
- tuga4u.com.db
- 192.168.1.rev

on the file tuga4u.com.db is this:
Quote:
$TTL 604800
@ IN SOA tuga4u.com. admin.tuga4u.com. (
2007061101 ; Serial
7200 ; Refresh
120 ; Retry
2419200 ; Expire
604800) ; Default TTL

;
IN NS dns.tuga4u.com.
IN A 192.168.1.103
IN NS ns
IN NS ns1.tuga4u.com
IN NS ns2.tuga4u.com




IN MX 10 mail.tuga4u.com.
@ IN A 192.168.1.103
boss IN A 192.168.1.103
www IN A 192.168.1.103
news IN A 192.168.1.103
mail IN A 192.168.1.103
dns IN A 192.168.1.103
dns2 IN A 192.168.1.103
(192.168.1.103 is the server where bind9 is executed)

On 192.168.1.rev is this:
Quote:
$TTL 1d ;
$ORIGIN 1.168.192.IN-ADDR.ARPA.
@ IN SOA ns1.tuga4u.com. info.tuga4u.com. (
2007011501
7200
120
2419200
604800
)
IN NS ns1.tuga4utuga4u.com.
IN NS ns2.tuga4u.com.
1 IN PTR ns1.tuga4u.com.
2 IN PTR ns2.tuga4u.com.



on /etc/bind i have this files:

-db.0
-db.127
-db.125
-db.empty
-db.local
-db.root
-named.conf
-named.conf.local
-named.conf.options
-rndc.key
-zones.rfc1918

-------------------------------------------------------------------

now, wenn i ping the host:

Quote:
ping ns1.tuga4u.com
Quote:
ping: unknown host ns1.tuga4u.com

ideas???
Reply With Quote
Sponsored Links
  #2  
Old 17th June 2007, 03:00
astra2000 astra2000 is offline
Junior Member
 
Join Date: Jun 2007
Posts: 20
Thanks: 4
Thanked 1 Time in 1 Post
Default

on var/log/daemon.log i have something like this:


Quote:
Jun 16 02:10:06 debian named[11679]: starting BIND 9.4.1 -u bind
Jun 16 02:10:06 debian named[11679]: found 2 CPUs, using 2 worker threads
Jun 16 02:10:06 debian named[11679]: loading configuration from '/etc/bind/named.conf'
Jun 16 02:10:06 debian named[11679]: listening on IPv6 interfaces, port 53
Jun 16 02:10:06 debian named[11679]: listening on IPv4 interface lo, 127.0.0.1#53
Jun 16 02:10:06 debian named[11679]: listening on IPv4 interface eth0, 192.168.1.103#53
Jun 16 02:10:06 debian named[11679]: automatic empty zone: 254.169.IN-ADDR.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.IP6.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.IP6.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: D.F.IP6.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: 8.E.F.IP6.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: 9.E.F.IP6.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: A.E.F.IP6.ARPA
Jun 16 02:10:06 debian named[11679]: automatic empty zone: B.E.F.IP6.ARPA
Jun 16 02:10:06 debian named[11679]: command channel listening on 127.0.0.1#953
Jun 16 02:10:06 debian named[11679]: command channel listening on ::1#953
Jun 16 02:10:06 debian named[11679]: zone 0.in-addr.arpa/IN: loaded serial 1
Jun 16 02:10:06 debian named[11679]: zone 127.in-addr.arpa/IN: loaded serial 1
Jun 16 02:10:06 debian named[11679]: /etc/bind/zones/master/192.168.1.rev:13: TTL set to prior TTL (1)
Jun 16 02:10:06 debian named[11679]: zone 1.168.192.IN-ADDR.ARPA/IN: loaded serial 2007011501
Jun 16 02:10:06 debian named[11679]: zone 255.in-addr.arpa/IN: loaded serial 1
Jun 16 02:10:06 debian named[11679]: zone tuga4u.com/IN: loaded serial 2007061101
Jun 16 02:10:06 debian named[11679]: zone localhost/IN: loaded serial 1
Jun 16 02:10:06 debian named[11679]: running
Jun 16 02:10:06 debian named[11679]: zone 1.168.192.IN-ADDR.ARPA/IN: sending notifies (serial 2007011501)
Jun 16 02:10:06 debian named[11679]: zone tuga4u.com/IN: sending notifies (serial 2007061101)

on /etc/resolv.conf

Quote:
search Cablecom
nameserver 62.2.17.60
nameserver 62.2.24.158
nameserver 62.2.17.61
Reply With Quote
  #3  
Old 17th June 2007, 14:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Does
Code:
dig @localhost ns1.tuga4u.com
work?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 18th June 2007, 00:18
astra2000 astra2000 is offline
Junior Member
 
Join Date: Jun 2007
Posts: 20
Thanks: 4
Thanked 1 Time in 1 Post
Default

debian:/home/virus# dig @localhost ns1.tuga4u.com
bash: dig: command not found
Reply With Quote
  #5  
Old 18th June 2007, 00:26
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
Default

Quote:
Originally Posted by astra2000
debian:/home/virus# dig @localhost ns1.tuga4u.com
bash: dig: command not found
Use dig localhost ns1.tuga4u.com (I think falko had a late night)

Also.. Your DNS should not have LAN IP's (192.168.1.103) in it,exept if you want to use it on your LAN only.
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
The Following User Says Thank You to edge For This Useful Post:
astra2000 (18th June 2007)
  #6  
Old 18th June 2007, 12:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by edge
Use dig localhost ns1.tuga4u.com (I think falko had a late night)
No,
Code:
dig @localhost ns1.tuga4u.com
is correct.

Please install dnsutils:
Code:
apt-get install dnsutils
and run
Code:
dig @localhost ns1.tuga4u.com
again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
astra2000 (18th June 2007)
  #7  
Old 18th June 2007, 16:14
astra2000 astra2000 is offline
Junior Member
 
Join Date: Jun 2007
Posts: 20
Thanks: 4
Thanked 1 Time in 1 Post
Default

Here is a quote

Quote:
debian:/home/virus# dig @localhost ns1.tuga4u.com

; <<>> DiG 9.4.1 <<>> @localhost ns1.tuga4u.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 21533
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ns1.tuga4u.com. IN A

;; Query time: 1 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Jun 18 16:06:49 2007
;; MSG SIZE rcvd: 32
Reply With Quote
  #8  
Old 18th June 2007, 16:18
astra2000 astra2000 is offline
Junior Member
 
Join Date: Jun 2007
Posts: 20
Thanks: 4
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by edge
Use dig localhost ns1.tuga4u.com (I think falko had a late night)

Also.. Your DNS should not have LAN IP's (192.168.1.103) in it,exept if you want to use it on your LAN only.

whitch io should i met there???
my external ip ???

Last edited by astra2000; 18th June 2007 at 16:22.
Reply With Quote
  #9  
Old 19th June 2007, 14:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by astra2000
my external ip ???
Yes, use public IP addresses, otherwise nobody from outside your LAN can access your web sites.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 19th June 2007, 14:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by astra2000
Here is a quote
There's no ANSWER section, which means that you local nameserver isn't configured to resolve ns1.tuga4u.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem whit instalation Centos 4.4 roghawas Installation/Configuration 5 12th May 2007 18:08
bind9 debian sarge etch remarks laliluna HOWTO-Related Questions 1 11th April 2007 12:02
Bind9 Master/Slave DNS System zimele Installation/Configuration 13 11th December 2006 13:43
installing Bind9 + DNSSec on Centos 4.4 HooGLaNDeR Server Operation 5 30th October 2006 21:52
bind9 and its use Ovidiu General 1 19th September 2005 14:56


All times are GMT +2. The time now is 09:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.