Prev Previous Post   Next Post Next
  #1  
Old 15th June 2007, 23:15
Liac Liac is offline
Junior Member
 
Join Date: Jun 2007
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Question .htaccess

Hello all.

First of all, I hope this is the right forum. Like the title suggests, this thread is all about .htaccess and the headache it causes for me.

To put it simply: it doesn't work. I have spent almost 2 hours trying to figure out why, googled trying to find a solution, but to no avail.

Here's my simple .htaccess:
Code:
ErrorDocument 404 custom404.php
My server is running on a local machine. I'm using Ubuntu Linux Server 7.04 with auto-configured Apache, PHP and MySQL. I must say, this is my first try with Linux ever (!), so if you give a Linux-specific answer, I'd appreciate if you explain it for a newbie .

In /etc/apache2/ I have created a link in "mods-enabled" to rewrite.load in "mods-available". I hope that this has loaded the module (and it apparently has since loading it again with "LoadModule rewrite_module modules/mod_rewrite.so" in apache2.conf issues a warning, that it has already been loaded).

In my apache2.conf, there are also these lines:
Code:
AccessFileName .htaccess
(And at the end...):
Code:
<directory />
AllowOverride All
Options All
</directory>
When I specify the contents of the .htaccess file ("ErrorDocument 404 custom404.php") directly in apache2.conf, it works perfectly. So I guess I have configured something wrong, so that .htaccess files are just ignored.

So, how to make .htaccess files work?

Any help would be really appreciated

Thanks in advance,
Liac
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
ISPConfig and .htaccess ionut89 Feature Requests 1 17th October 2006 17:45
.htaccess login challenge broken with mod_rewrite ozonblue Installation/Configuration 2 13th September 2006 10:09
.htaccess never executed galmiche Server Operation 2 4th June 2006 21:44
No .htaccess in automatic backup? tron Installation/Configuration 3 22nd March 2006 18:03


All times are GMT +2. The time now is 16:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.