Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 25th May 2007, 22:33
swggy swggy is offline
Junior Member
 
Join Date: May 2007
Posts: 11
Thanks: 5
Thanked 0 Times in 0 Posts
Default The classic MySQL connect error

Newbie speaking…

I've followed the 'perfect setup for CentOS 5.0' and I've got everything running fairly well. However, I can't fire up my test MySQL script - I get
Quote:
Fatal error: Call to undefined function mysql_connect() in /var/www/web8/web/.../mysql_up.php on line 12
So I went to the search engine and found 42,900 occurrences of this. I've poked around in the forums and found near hits to answer my problem, but nothing exact - one of the problems I'm bumping into is that so many of the answers presume that PHP is running on Windows, which doesn't really help me.

* I understand that MySQL isn't turned on by default in PHP5.
* I understand that MySQL is loaded on my system, since I'm running ISPConfig and it uses MySQL.
* I understand that my PHP probably doesn't have MySQL installed as an extension, since phpinfo says
Quote:
'--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd'
and there's no table further down for it (I rather thought that 'the perfect setup' for a LAMPS install would automatically have php with MySQL, but that's another story.)

So I'm wondering - how to activate MySQL in PHP5, and it seems as if I have to recompile PHP. I’ve got 3 questions:

1) I’m guessing that I can take the entire configure command in the big box at the top of the phpinfo() display and run that (tweaking the ‘-–without-mysql’ of course). True?
2) What directory do I run this from? There’s a pile of ‘.h’ files in ‘/usr/include/php/main’ - do I go there? Or where?
3) Do I need anything else?

Thanks for any help ...
swggy
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42
Frustrated with ISPConfig install! woozyerdaddee Installation/Configuration 4 19th May 2006 03:38
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 16:14
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 18:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.