Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 18th May 2007, 18:59
qtx qtx is offline
Junior Member
 
Join Date: Oct 2006
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Unhappy Virtual Users And Domains With Postfix, Courier And MySQL - SASLauthd problem

Hello ever'1

I know, it's a shame and I must be the xth member to post a message here about this issue, but no advice proved to work on my machine.

The setup is a brand new Debian 4.0.
I followed the HOWTO 'Virtual Users And Domains With Postfix, Courier And MySQL - ubuntu'.
During the installation no errors occured, so it cannot be totally screwed.

What is the (my) problem?
It is not possible to send/receive emails via a client (thunderbird in my case).

I can track the following error in:
/var/log/mail.log
Code:
May 18 18:41:39 myserver courierpop3login: Connection, ip=[::ffff:xx.xx.37.7]
May 18 18:41:53 myserver authdaemond: failed to connect to mysql server (server=localhost, userid=mail_admin): Access denied for user 'mail_admin'@'localhost' (using password: YES)
May 18 18:41:53 myserver courierpop3login: LOGIN FAILED, user=info@mydomain.tld, ip=[::ffff:xx.xx.37.7]
May 18 18:41:53 myserver courierpop3login: authentication error: Input/output error
So when trying to pop/send emails from my mailserver it refuses all delivery (no matter what direction). It's not a thunderbird issue, for sure.

I checked my files according to the postings in this forum and the howto (especially the ones that differ from the ubuntu installation) and I cannot find any differences.

So all the saslauthd, mysql etc. conf-files look the same.
The *mail_admin*-user is registered in mysql (login to mysql works just fine).

I was able to send emails via telnet and I also receive emails in /home/vmail/.

Right now I am stuck and do not know, why saslauthd cannot connect to mysql. I know, something must be missing, though!
/var/log/syslog does not tell me anything else.

Any debugging hints are highly appreciated!

Thanks!
Qt
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL wmrwl HOWTO-Related Questions 73 6th October 2006 23:06
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs k1piee HOWTO-Related Questions 14 1st October 2006 13:46
Autoreply problem using Virtual Users And Domains With Postfix, Courier And MySQL triak HOWTO-Related Questions 1 19th May 2006 15:25
Problem with Virtual Users And Domains With Postfix, Courier And MySQL Howto fenix Server Operation 4 11th March 2006 02:53
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41


All times are GMT +2. The time now is 14:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.