Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th April 2007, 02:25
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default suhosin installation and php.ini changes

I've compile php with the suhosin patch like this:
Code:
./configure --enable-memory-limit --enable-force-cgi-redirect --with-gd --with-jpeg --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib --enable-track-vars --with-pcre-regex --with-mysql --with-bz2 --enable-inline-optimization --disable-debug --with-regex=php --disable-rpath --without-sqlite --without-mm --enable-fastcgi --with-zlib --prefix=/var/www/php-fcgi-scripts/php5.2.1-fcgi-suhosin --enable-suhosin
But phpinfo() only shos this extensions:
below
Configuration
PHP Core

...
Quote:
sql.safe_mode Off Off
suhosin.log.phpscript 0 0
suhosin.log.phpscript.is_safe Off Off
suhosin.log.phpscript.name no value no value
suhosin.log.sapi no value no value
suhosin.log.script no value no value
suhosin.log.script.name no value no value
suhosin.log.syslog no value no value
suhosin.log.syslog.facility no value no value
suhosin.log.syslog.priority no value no value
suhosin.log.use-x-forwarded-for Off Off
track_errors Off
There is no other section like in falkos howto called sohusin with extenions like:
sohusin_apc_bug_workaround

and others more. Why they are not there?
Do I have to put them in the php.ini but where do I find them?
Reply With Quote
Sponsored Links
  #2  
Old 21st April 2007, 12:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by tom
There is no other section like in falkos howto called sohusin with extenions like:
sohusin_apc_bug_workaround
This happens because you didn't install the php5-suhosin package, but compiled everything from the sources. I guess there are special options that you have to specify in the ./configure string to get the other sections as well. Take a look at the Suhosin documentation and the installation instructions in the Suhosin sources.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 23rd April 2007, 13:10
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by falko
This happens because you didn't install the php5-suhosin package ...
right, I only patched the php.

Now I've even installed the php5-suhosin package and copied it to /php/ext and changed the extension path in the php.ini and the suhosin directives are visible in phpinfo().
Is that the right way to do it or is there a default php.ini with all default suhosin directives and comments in it?

I used an old php.ini because I did'nt found a specific suhosin php.ini.

Last edited by tom; 23rd April 2007 at 15:18.
Reply With Quote
  #4  
Old 24th April 2007, 18:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

If you see the suhosin options now in your phpinfo page, then you modified the correct php.ini.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need to change toggle settings of php.ini file in SSH bpstyle Installation/Configuration 4 13th February 2007 11:33
FATAL ERROR: register_globals is disabled in php.ini, please enable it wvsailor Installation/Configuration 4 20th September 2006 19:45
php.ini ?!! gabykh Installation/Configuration 3 28th July 2006 20:15
double apache installation (with php) aolex Installation/Configuration 3 19th October 2005 17:04
Wrong php.ini? roadrunner Programming/Scripts 1 26th April 2005 15:29


All times are GMT +2. The time now is 12:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.