#1  
Old 16th November 2005, 23:26
MarcoV MarcoV is offline
Junior Member
 
Join Date: Nov 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Post Getting .php as source

I followed the perfect setup debian sarge howto today and finished it, then i installed ispconfig it was all working fine, at least until i change something in apache2.conf and restarted apache2 with /etc/init.d/apache2 restart.
Now i am getting my .php files as the source text.

Does someone has a solution for this problem, or now where i have to look to fix this?
Reply With Quote
Sponsored Links
  #2  
Old 17th November 2005, 01:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What did you change in your apache2.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th November 2005, 07:29
MarcoV MarcoV is offline
Junior Member
 
Join Date: Nov 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

To enable name look up for apache, i changed it back off but then i stell get the .php files as there source
Reply With Quote
  #4  
Old 17th November 2005, 09:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Where do you see the PHP sources? In a web site you created with ISPConfig (did you enable PHP for that web site in ISPConfig?), or in a web site that existed before you installed ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 17th November 2005, 11:29
MarcoV MarcoV is offline
Junior Member
 
Join Date: Nov 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

In a website that excisted before i installed ispconfig
Reply With Quote
  #6  
Old 17th November 2005, 11:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,990
Thanks: 825
Thanked 5,373 Times in 4,220 Posts
Default

ISPConfig disables PHP for existing sites. Create the site in ISPConfig again and copy the contents of the existing site to the new directory created by ISPConfig.
Reply With Quote
  #7  
Old 17th November 2005, 14:23
MarcoV MarcoV is offline
Junior Member
 
Join Date: Nov 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

It is working now, i have configured ispconfig and it is working like it should.
I gues when i restarted apache to apply the changes i made he also restarted with the changes ispconfig made.

Edit:
Just wanted to say that ispconfig is very nice to work with, and it is free too !
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig Firewall and no sense MyLinux General 7 9th September 2005 17:35
ProFTPD Logins and Authentication pete General 9 14th August 2005 23:24
Problem opening firewall port weedguy General 15 12th August 2005 01:05
Why install from source instead of debian packages? TheMike HOWTO-Related Questions 3 27th July 2005 10:40
Apache from source on SuSE 9 Brenton Server Operation 1 25th July 2005 18:40


All times are GMT +2. The time now is 14:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.