#1  
Old 23rd November 2005, 15:31
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default Enable PAE on SMP kernel

I hope someone can answer. I have Debi kernel 2.6 SMP. Is there a way to enable PAE and how can I prove that PAE is in fact enabled. procinfo flag says my P4 HT is capable and my board can in fact support 4gig of ram. Here is the question. How can I enable PAE in the kernel without acually having 4gig of memory?
Reply With Quote
Sponsored Links
  #2  
Old 24th November 2005, 14:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's PAE?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th November 2005, 21:24
heyp heyp is offline
Junior Member
 
Join Date: Sep 2005
Location: Vienna
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Physical Address Extension
Reply With Quote
  #4  
Old 27th November 2005, 23:08
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

Never mind. We just wanted to see if we could do the same thing as you can add the /PAE switch in boot.ini in windows.

Thanks
Reply With Quote
  #5  
Old 9th April 2007, 23:10
fbg00 fbg00 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default You might want to rebuild the kernel

AFAIK, you have to rebuild the kernel if PAE support isn't there and you want it. Rebuilding the kernel is generally easy if you start from a working config file, but it takes a while (10's of minutes). For example, if you're using Debian Sarge and a 2.6.x kernel, see this link: http://www.howtoforge.com/forums/showthread.php?t=21 but of course change the kernel version to match the one you have. Copy your /boot/config<your-version> to /usr/src/linux-<your-version>/.config. Assuming you do this and the config file is in the right place, and that you need no other changes, when you run "make menuconfig" all you need to do is turn on the appropriate option for PAE (for me this was "Processor type and features ---> High Memory Support ---> 64GB" but you may want only 4GB, and/or YMMV depending on the kernel version you've got). Good luck.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile Kernel 2.6 under Debian Sarge falko Kernel Questions 117 28th September 2009 13:03
Newbies question about recompiling kernel aakk HOWTO-Related Questions 7 5th November 2005 20:38
Apache not adding domains adamluz Server Operation 3 16th August 2005 20:20
Use kernel 2.4 config for kernel 2.6? rookie Kernel Questions 1 20th May 2005 15:15
Install Debian Sarge with Kernel 2.6 root Installation/Configuration 4 10th May 2005 10:51


All times are GMT +2. The time now is 18:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.