Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th April 2007, 15:55
hayesben hayesben is offline
Junior Member
 
Join Date: Mar 2007
Location: Peterborough, England
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Using Sharp Fonts On A GNOME Desktop

Falko

I've followed your instructions on using the MS fonts (as well as copying the Tahoma fonts over to Ubuntu). However, everything goes good until I change over to the Tahoma fonts. What happens is instead of seeing better looking text on the screen, I get block symbols all across the screen (instead of letters/words). At first I thought I had a corrupt font file so I re-copied it again from a different Windows machine and went through the process again and the same result. I'm running Ubuntu v6.10 (not the 7.04 beta release). To get around this I changed things over to Sans with a 8 pt font. Not the same but usable. Any ideas on what would cause this issue and/or is there a possible fix/work around.

Ben
Reply With Quote
Sponsored Links
  #2  
Old 9th April 2007, 23:04
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,430
Thanks: 813
Thanked 5,208 Times in 4,084 Posts
Default

I guess it is a problem with your locales. Which locale do you use on your linux workstation?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th April 2007, 06:36
hayesben hayesben is offline
Junior Member
 
Join Date: Mar 2007
Location: Peterborough, England
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Till

The locale used is:

en_GB.UTF-8

Ben
Reply With Quote
  #4  
Old 10th April 2007, 15:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

That's the same locale I use on my system...
You can run
Code:
sudo dpkg-reconfigure locales
and select iso8859-1 instead of UTF8. Maybe that changes the behaviour.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th April 2007, 16:04
hayesben hayesben is offline
Junior Member
 
Join Date: Mar 2007
Location: Peterborough, England
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko

Thanks for the input. I'll re-install v6.10 tonight. I did a Ubuntu v7.04 install and your guide worked flawlessly. But I'll try again with the v6.10 tonight and letcha know it goes (as I want to test something else out as well).

Ben
Reply With Quote
  #6  
Old 11th April 2007, 23:06
hayesben hayesben is offline
Junior Member
 
Join Date: Mar 2007
Location: Peterborough, England
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko

Well, I've re-installed Ubuntu v6.10 onto my computer and followed your How-To and it's worked perfectly this time around. The only thing I can think of is that I missed a step in your How-To which caused this to go haywire a bit. Anyway, thanks for the How-To!

Ben
Reply With Quote
  #7  
Old 26th April 2007, 21:01
Chad Chad is offline
Member
 
Join Date: Apr 2007
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
That's the same locale I use on my system...
You can run
Code:
sudo dpkg-reconfigure locales
and select iso8859-1 instead of UTF8. Maybe that changes the behaviour.
Generating locales...
en_AU.UTF-8... done
en_BW.UTF-8... done
en_CA.UTF-8... done
en_DK.UTF-8... done
en_GB.UTF-8... done
en_HK.UTF-8... done
en_IE.UTF-8... done
en_IN.UTF-8... done
en_NZ.UTF-8... done
en_PH.UTF-8... done
en_SG.UTF-8... done
en_US.UTF-8... up-to-date
en_ZA.UTF-8... done
en_ZW.UTF-8... done
Generation complete.


What do you mean select iso... ?

Where? How? I still show blocks on Tahoma
Reply With Quote
  #8  
Old 27th April 2007, 14:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

When you run
Code:
sudo dpkg-reconfigure locales
, you can s lect iso8859-1.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 27th April 2007, 15:29
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Quote:
Originally Posted by falko
That's the same locale I use on my system...
You can run
Code:
sudo dpkg-reconfigure locales
and select iso8859-1 instead of UTF8. Maybe that changes the behaviour.
That works a little bit different on Ubuntu.

Have a look here for example:
http://blog.andrewbeacock.com/2007/0...locale-on.html
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #10  
Old 13th July 2007, 08:13
mesibov mesibov is offline
Junior Member
 
Join Date: Jul 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Another way to sharpen

I run Gnome with Verdana 10pt as default font for everything. To my eyes, text looks very clean and sharp if my settings (System/Preferences/Font) are:
Font Rendering: Monochrome
(Details) Smoothing: None
(Details) Hinting: Full.

I wonder how this compares with falko's tweaking and Tahoma?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SASL Auth daemon failure millson249 HOWTO-Related Questions 7 16th August 2011 12:05
Installing Debian desktop GNOME! AdykOSu Installation/Configuration 13 9th January 2011 23:43
Sharp fonts for Fedora How-To? markg85 HOWTO-Related Questions 12 19th April 2007 14:46
Swap suse10 desktop mphayesuk Desktop Operation 2 22nd February 2006 19:14
MS true type fonts in Fedora domino Installation/Configuration 2 28th October 2005 20:59


All times are GMT +2. The time now is 10:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.