Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 9th April 2007, 08:57
lychee_lch lychee_lch is offline
Junior Member
 
Join Date: May 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Question mysql-cluster load balancing problem !!

I have follow every step of how to mysql cluster and load balancing, But when i reach the page 7 "prepare the mysql cluster node for load balancing",after i type "ifup lo:0" .. Then i check the management node typed "ndb_mgm" >> "show". It show

=============================================
Cluster Configuration
---------------------
[ndbd(NDB)] 2 node(s)
id=2 (not connected, accepting connect from 10.100.100.102)
id=3 (not connected, accepting connect from 10.100.100.103)

[ndb_mgmd(MGM)] 1 node(s)
id=1 @10.100.100.101 (Version: 5.0.27)

[mysqld(API)] 2 node(s)
id=4 (not connected, accepting connect from any host)
id=5 (not connected, accepting connect from any host)

==============================================
This show all the node have been disconnected when i typed "ifup lo:0"

1) Is this normal when i typed ifup lo:0 the mysql cluster will disconnected, i cant even online with the both sql node ....????

I donno this situation is normal or not, so i proceed to nex step. Everything look same in the tutorial except i came to a step where i typed "ipvsadm -L -n" and the result is ...

=============================================
IP Virtual Server version 1.2.1 (size=4096)
Prot LocalAddress:Port Scheduler Flags
-> RemoteAddress:Port Forward Weight ActiveConn InActConn
TCP 10.100.100.105:3306 wrr
-> 10.100.100.103:3306 Route 0 0 0
-> 10.100.100.102:3306 Route 0 0 0
=============================================


whereby, the "weight" is "0" and in tutorial is "1" (actually i not really understand what does the weight means... ) T_T

so without any choice, i still proceed to another step until "mysql -h 10.100.100.105 -u ldirector -p " with the correct password. But after i login, i try to use the "select all from connectioncheck table" and it say

"Error 1105 (HY000): Failed to open 'connectioncheck', error while unpacking from engine"

2) Is there other way to check the whole cluster-load balancer configured right ?
3) Can i use the same one of the my four pc to access mysql ??
4) The same network other pc that mentioned must installed mysql to access my virtual ip mysql ?

Please help and give some advise !!!!! thanks .....
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
MySQL Cluster HOWTO - Cannot load Virtual IP address samu HOWTO-Related Questions 6 11th January 2007 10:19
MySQL Cluster On FC5 : error while unpacking from engine asyadiqin HOWTO-Related Questions 7 28th October 2006 17:37
problem with load-balanced mysql cluster MvdB HOWTO-Related Questions 4 16th October 2006 11:15
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 19:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.