Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 11th November 2005, 18:41
ggere ggere is offline
Junior Member
 
Join Date: Nov 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay, checked the /etc/postfix/main.cf and the proxy_read_maps line was there. So I removed the proxy part from the virtual_mailbox_maps line and receive no more errors in my mail.log file.

I sent a test message from the "admin" account to "postmaster@portfoliomci.com" and this is the log notes:

Code:
Nov 11 12:37:45 email postfix/pickup[24057]: B567A8B2C: uid=1000 from=<admin>
Nov 11 12:37:45 email postfix/cleanup[24086]: B567A8B2C: message-id=<20051111173745.GA24066@email.portfoliomci.com>
Nov 11 12:37:45 email postfix/qmgr[24058]: B567A8B2C: from=<admin@email.portfoliomci.com>, size=459, nrcpt=1 (queue active)
Nov 11 12:37:47 email postfix/smtpd[24097]: connect from localhost.localdomain[127.0.0.1]
Nov 11 12:37:47 email postfix/smtpd[24097]: D512C8B2B: client=localhost.localdomain[127.0.0.1]
Nov 11 12:37:47 email postfix/cleanup[24086]: D512C8B2B: message-id=<20051111173745.GA24066@email.portfoliomci.com>
Nov 11 12:37:47 email postfix/qmgr[24058]: D512C8B2B: from=<admin@email.portfoliomci.com>, size=940, nrcpt=1 (queue active)
Nov 11 12:37:47 email amavis[21587]: (21587-01) Passed, <admin@email.portfoliomci.com> -> <postmaster@portfoliomci.com>, Message-ID: <20051111173745.GA24066@email.portfoliomci.com>, Hits: -1.72
Nov 11 12:37:47 email postfix/smtpd[24097]: disconnect from localhost.localdomain[127.0.0.1]
Nov 11 12:37:47 email postfix/smtp[24091]: B567A8B2C: to=<postmaster@portfoliomci.com>, relay=127.0.0.1[127.0.0.1], delay=2, status=sent (250 2.6.0 Ok, id=21587-01, from MTA: 250 Ok: queued as D512C8B2B)
Nov 11 12:37:47 email postfix/qmgr[24058]: B567A8B2C: removed
Nov 11 12:37:48 email postfix/smtp[24101]: D512C8B2B: to=<postmaster@portfoliomci.com>, relay=mail.portfoliomci.com[192.168.1.4], delay=1, status=sent (250 ok 1131730673 qp 2896)
Nov 11 12:37:48 email postfix/qmgr[24058]: D512C8B2B: removed
Still not able to login from Thunderbird however.

Last edited by ggere; 11th November 2005 at 18:47.
Reply With Quote
Sponsored Links
  #12  
Old 12th November 2005, 19:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

Quote:
Originally Posted by ggere
Still not able to login from Thunderbird however.
When you want to send emails, or when you try to fetch emails? Or both?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 14th November 2005, 14:54
ggere ggere is offline
Junior Member
 
Join Date: Nov 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

IMAP is what I'm testing at the moment, so receiving emails. But I believe sending isn't working either. Note: I can send via mutt on the server between real accounts, but I can't test virtual accounts in this way.
Reply With Quote
  #14  
Old 14th November 2005, 15:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

Did you use Debian stable or testing to install the server? Because in the tutorial I use stable which comes with Postfix 2.1.5, but testing comes with Postfix 2.2.x, and since 2.2 the format of the lookup files has changed.

Have a look here: http://www.howtoforge.com/forums/sho...?t=1149&page=4

Which Postfix version do you have? Run
Code:
postconf -d | grep mail_version
to find out.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 14th November 2005, 15:46
ggere ggere is offline
Junior Member
 
Join Date: Nov 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm using stable:

Code:
[root@email:~]# postconf -d | grep mail_version
mail_version = 2.1.5
I think this may have to do with me not having the dns information completely setup yet, instead I'm trying to connect to ggere@192.168.1.37 (the internal IP of the email server) and I have 192.168.1.37 in my domains table and a user ggere@192.168.1.37 in the users table. I will try to get my dns information setup today and see if that helps.

If you think this isn't what is causing the problem feel free to continue and try to help, I really appreciate your input. Otherwise perhaps it would be best to wait until the dns setup is complete.

Thanks.
Reply With Quote
  #16  
Old 14th November 2005, 16:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
 
Default

Quote:
Originally Posted by ggere
If you think this isn't what is causing the problem feel free to continue and try to help, I really appreciate your input. Otherwise perhaps it would be best to wait until the dns setup is complete.
Let's wait until DNS is set up.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota... killfrog HOWTO-Related Questions 3 25th September 2009 21:45
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54


All times are GMT +2. The time now is 11:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.