#1  
Old 13th March 2007, 18:16
debian_debbie debian_debbie is offline
Junior Member
 
Join Date: Mar 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't get SMTP Server to work

Hello,

I've followed
http://www.howtoforge.com/perfect_setup_debian_sarge
and then this
http://www.howtoforge.com/perfect_setup_debian_sarge
(missing out the quota patch part)

and while I can now receive emails to my virtual accounts (both pop and imap) and send emails from telnet localhost 25, I can't get the server to allow Thunderbird to send emails.

My /var/log/mail.log says the following...

Code:
Mar 13 17:10:00 servername postfix/smtpd[8823]: starting TLS engine
Mar 13 17:10:00 servername postfix/smtpd[8823]: connect from myIP[xxx.xxx.xxx.xxx]
Mar 13 17:10:06 servername postfix/smtpd[8823]: warning: SASL authentication failure: Password verification failed
Mar 13 17:10:06 servername postfix/smtpd[8823]: warning: myIP[xxx.xxx.xxx.xxx]: SASL PLAIN authentication failed
Mar 13 17:10:06 servername postfix/smtpd[8823]: warning: myIP[xxx.xxx.xxx.xxx]: SASL LOGIN authentication failed
Mar 13 17:10:07 servername postfix/smtpd[8823]: disconnect from myIP[xxx.xxx.xxx.xxx]

Anyone got any ideas as to what I've done wrong?

Thank you in advance
Reply With Quote
Sponsored Links
  #2  
Old 13th March 2007, 23:35
debian_debbie debian_debbie is offline
Junior Member
 
Join Date: Mar 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Nevermind, I've fixed it.

saslauthd had become zombied, and thus I assume ignored a change to /etc/pam.d/smtp.

Killed the pid, checked the files, changed it back to an earlier version, /etc/init.d postfix restart, postfix check, /etc/init.d/saslauthd restart


thanks anyway
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30
POP3 SMTP FTP problem arsu Installation/Configuration 1 11th November 2005 09:32


All times are GMT +2. The time now is 14:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.