Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th March 2007, 13:43
andyreynolds andyreynolds is offline
Junior Member
 
Join Date: Jan 2007
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default emails not working

Hi
I have now got the server hosting the domain vsk-gbr.com with joomla on it but I don't know how to get the mail servers to work. if you go to dnsstuff.com it says that it can connect to the mail servers through ns1.srhosting.net, but reading the mini how to tutorial I would of though that mail.vsk-gbr.com was the mail server but it turns out to be ns2.srhosting.net and when I send an e-mail it doesn't turn up at the inbox of which I sent it to. I have checked with my ISP and they don't block any ports, so i can't see what is wrong, can someone point me in the right direction,

Cheers
Andy
Reply With Quote
Sponsored Links
  #2  
Old 14th March 2007, 21:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

ns1.srhosting.net is the server that handles emails for vsk-gbr.com:

Code:
mh1:~# dig mx vsk-gbr.com

; <<>> DiG 9.2.1 <<>> mx vsk-gbr.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 35775
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;vsk-gbr.com.                   IN      MX

;; ANSWER SECTION:
vsk-gbr.com.            86400   IN      MX      10 ns1.srhosting.net.

;; Query time: 160 msec
;; SERVER: 213.191.92.84#53(213.191.92.84)
;; WHEN: Wed Mar 14 21:55:38 2007
;; MSG SIZE  rcvd: 62
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th March 2007, 14:06
andyreynolds andyreynolds is offline
Junior Member
 
Join Date: Jan 2007
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default mx

Hi Falko

So am I right in asuming that ns1.srhosting.net is the mail server for all of my domains. When I am in the dns entries section for vsk-gbr I have a mx record ns1.srhosting.net and an A record for ns1 that points to 91.84.34.130. But when I go into round cube and send an e-mail it comes back with an error message. When I send an e-mail to dan@vsk-gbr.com nothing appears in the inbox, why is this?

Cheers
Andy
Reply With Quote
  #4  
Old 16th March 2007, 17:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by andyreynolds
But when I go into round cube and send an e-mail it comes back with an error message.
What's the exact error message? What's in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th March 2007, 18:58
andyreynolds andyreynolds is offline
Junior Member
 
Join Date: Jan 2007
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default error message

Mail FAIL Connect to mail servers ERROR: I could not complete a connection to any of your mailservers!

ns1.srhosting.net: Timed out [Last data sent: RCPT TO: ]

If this is a timeout problem, note that the DNS report only waits about 40 seconds for responses, so your mail *may* work fine in this case but you will need to use testing tools specifically designed for such situations to be certain.
Reply With Quote
  #6  
Old 17th March 2007, 18:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,405
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

You should consider to reinstall your server exactly as described in the perfect setup manual for your linux distribution, this will be most likely much faster then finding this problem in your current sendmail installation.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 17th March 2007, 18:41
andyreynolds andyreynolds is offline
Junior Member
 
Join Date: Jan 2007
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default server

I have installed postfix so that when you do the dns-stuff.com test it shows up that it can connect every time to the mail server. The messages get sent a lot quicker, but if I send an internal e-mail from one hosted domain to the other it doesn't appear in that inbox, why is this?
Reply With Quote
  #8  
Old 17th March 2007, 18:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,405
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Originally Posted by andyreynolds
I have installed postfix so that when you do the dns-stuff.com test it shows up that it can connect every time to the mail server. The messages get sent a lot quicker, but if I send an internal e-mail from one hosted domain to the other it doesn't appear in that inbox, why is this?
Which pop3 / imap daemon do you have installed? Please post an excerpt of your mail logfile.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 17th March 2007, 19:30
andyreynolds andyreynolds is offline
Junior Member
 
Join Date: Jan 2007
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default daemon

I have dovecot, is this ok?
Reply With Quote
  #10  
Old 18th March 2007, 19:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Dovecot is ok, but make sure that Maildir is enabled in ISPConfig (Mangement -> Server -> Settings -> Email).
Also make sure that SELinux is disabled.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS stop working MZH General 3 22nd February 2008 11:10
Emails suddenly not working -- centos3 and ispconfig mxc General 5 16th November 2006 14:54
ftp not working pesja Installation/Configuration 3 17th July 2006 12:37
Sending mails to remote domains is not working. nandhu HOWTO-Related Questions 17 20th February 2006 20:27
Emails received but I cannot read them skeeta Installation/Configuration 2 28th August 2005 12:24


All times are GMT +2. The time now is 00:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.