#1  
Old 7th March 2007, 15:01
Z3n Z3n is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to Z3n Send a message via MSN to Z3n Send a message via Yahoo to Z3n
Default Xen and Apache / NFS Cluster

I am currently working on a proof of concept idea that I had and ran into a bit of trouble. I am using the Apache Cluster Howto and the HA NFS Howto and trying to build it all in Xen environments.

I currently have the loadbalancers and webservers running in virtual environments with them acting exactly as the should. Very neat.

Problem I am having is with the NFS server. In the howto you are to create two partitions, one for the DRBD database and the other for your data export, but you are not supposed to mount them. Cool, I create the LVM volumes for them and include them in the disk= statement:

disk=['phy:/dev/vserver/dbtc01,hda1,w','phy:/dev/vserver/dbtc01-swap,hda2,w','phy:/dev/vserver/dbtc01-drbd,hda3,w','phy:/dev/vserver/dbtc01-export,hda4,w']

Now if I don't have the drbd and export drives defined in /etc/fstab xen fails to boot the system becasue of a hotplug error. But I can't have them mounted in the system because drbd needs to take care of that. So, I am here reaching out to anyone who may be able to direct me in the right direction to make this all work.

My host machine is Debian Etch running libc6-xen and Xen 3.0.3. No custom domU kernel is being used right now. I am just booting the running dom0 kernel for my domU systems.

Thanks in advance for any advice...
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2007, 18:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Quote:
Originally Posted by Z3n
Now if I don't have the drbd and export drives defined in /etc/fstab xen fails to boot the system becasue of a hotplug error.
Can you post the exact error message here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xen networking configuration cifroes Installation/Configuration 1 14th November 2006 14:25
Xen Debian 3 lib depenency errors unclecameron Installation/Configuration 3 11th April 2006 14:26
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30


All times are GMT +2. The time now is 17:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.