#1  
Old 26th February 2007, 16:39
AkumA AkumA is offline
Junior Member
 
Join Date: Jan 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default ASSP + ClamAv @ boot

Here i am with another question.
I got my Ubuntu Server 6.06 and i've configured ASSP to work with ClamAv.

I've checked the "ClamAv" option and i've searched in internet about my location of Clamav socket, and i've found it here
Code:
/var/run/clamav/clamd.ctl
The problem is:
on boot i get
Code:
Feb-26-07 16:17:35 ASSP version 1.2.5(2) (Perl 5.008007) initializing 
Feb-26-07 16:17:35 File::Scan::ClamAV module installed but not available, error: Cannot connect to unix
                   socket '/var/run/clamav/clamd.ctl': connect: No such file or directory
If i restart assp when server is ready it says that there are no problem.

I've changed the following, trying to put ASSP in a different position on my boot:
S20assp -> S99assp

I have S20clamav too in my
Code:
/etc/rc2.d/
(I have runlevel 2 in
Code:
/etc/inittab
)

But the results are the same..
it's strange because this morning i've tried simply with S21assp and it worked!
I've rebooted the machine once again but it returned the same error.

I can't understand why
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2007, 16:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
ls -l /bin/sh
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th February 2007, 10:29
AkumA AkumA is offline
Junior Member
 
Join Date: Jan 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
What's the output of
Code:
ls -l /bin/sh
?

Code:
lrwxrwxrwx 1 root root 4 2007-02-14 14:17 /bin/sh -> bash
Reply With Quote
  #4  
Old 28th February 2007, 12:02
AkumA AkumA is offline
Junior Member
 
Join Date: Jan 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I tought it was a Clamav file, now i've discovered that it's a clamav-daemon file (/var/run/clamav/clamav.ctl).

I've made a cronjob for updating clamav with freshclamav; in this way i could check it out on webmin (User gets email from cronjobs), so i've removed clamav-daemon.

I've reinstalled it and now after a few reboots seems to work (I've changed again S20assp to S21assp in /etc/rc2.d/ )

In assp Clamav is set as a daemon so it is coherent.. but i tought that clamav-daemon was just a daemon for checking updates!

EDIT: i read now that it's preferred to clamavscanner because it's faster.. d'oh!!!
Ok, i've read too much things all together and i haven't read them so well..

Now it seems to work (4 reboots)..

Last edited by AkumA; 28th February 2007 at 12:08.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
assp tutorial port 25 woes dkrysak HOWTO-Related Questions 11 4th January 2007 15:07
linux boot process sysconfig Server Operation 0 4th November 2006 09:58
Clamav starting error scherpenzeel Installation/Configuration 3 19th May 2006 14:01
xen not booting qiu HOWTO-Related Questions 11 2nd May 2006 10:20
ClamAV for postfix-courier-mysql (Debian - Sarge) toastmaster HOWTO-Related Questions 2 24th February 2006 19:00


All times are GMT +2. The time now is 14:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.